aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
diff options
context:
space:
mode:
authorTim Orling <TicoTimo@gmail.com>2014-07-15 15:42:55 -0700
committerTim Orling <TicoTimo@gmail.com>2014-07-15 15:42:55 -0700
commita6acceb1dc1d391e20c3722e685aa7c9cca313b3 (patch)
treec31a773a177c030ed638252f99755c9be8ec9c12 /meta-python/recipes-python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
parentdf9ed3b72b1920938e4c79c20cdd288a1d7b16a8 (diff)
downloadmeta-openembedded-contrib-timo/meta-python.tar.gz
meta-python: move recipes from meta-oetimo/meta-python
* Move recipes from meta-openembedded/meta-oe that are not depended upon by recipes already in meta-oe (e.g. gateone, anki) * Recipes NOT moved: python-futures python-pyopenssl python-simplejson python-tornado python-pyqt python-sip Signed-off-by: Tim Orling <TicoTimo@gmail.com>
Diffstat (limited to 'meta-python/recipes-python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch')
-rw-r--r--meta-python/recipes-python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-python/recipes-python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch b/meta-python/recipes-python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
new file mode 100644
index 0000000000..bcbdf24bb5
--- /dev/null
+++ b/meta-python/recipes-python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
@@ -0,0 +1,39 @@
+From f11b9c71080513f9b867ba8f40613ba2ebc6e960 Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Fri, 29 Mar 2013 15:17:17 +0100
+Subject: [PATCH] setup.py: link in sysroot, not in host directories
+
+Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
+
+Upstream-status: Unknown
+---
+ setup.py | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index e7c49eb..8deaa34 100644
+--- a/setup.py
++++ b/setup.py
+@@ -40,7 +40,7 @@ class _M2CryptoBuildExt(build_ext.build_ext):
+ self.openssl = 'c:\\pkg'
+ else:
+ self.libraries = ['ssl', 'crypto']
+- self.openssl = '/usr'
++ self.openssl = os.environ.get( "STAGING_DIR" )
+
+
+ def finalize_options(self):
+@@ -49,8 +49,8 @@ class _M2CryptoBuildExt(build_ext.build_ext):
+
+ build_ext.build_ext.finalize_options(self)
+
+- opensslIncludeDir = os.path.join(self.openssl, 'include')
+- opensslLibraryDir = os.path.join(self.openssl, 'lib')
++ opensslIncludeDir = os.environ.get( "STAGING_INCDIR" )
++ opensslLibraryDir = os.environ.get( "STAGING_LIBDIR" )
+
+ self.swig_opts = ['-I%s' % i for i in self.include_dirs + \
+ [opensslIncludeDir]]
+--
+1.8.1.4
+