aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorAlex Stewart <alex.stewart@ni.com>2017-10-24 14:27:54 -0500
committerArmin Kuster <akuster808@gmail.com>2017-11-15 16:31:29 -0800
commit08782a65651fef63ee9ff2ffd312adc573b7241b (patch)
tree9f37b9e21d6d72127d05f649d6e17a8e05a1a238 /meta-python
parent9245c2a7ec30ba5df6826acd91d7a76d7f51d017 (diff)
downloadmeta-openembedded-contrib-08782a65651fef63ee9ff2ffd312adc573b7241b.tar.gz
python-future: add new recipe
python-future is a compatibility library allowing python3.x code to run on python2.x runtimes. This package also includes the 'futurize' utility to convert python2 code to python2/3 agnositic code. Signed-off-by: Alex Stewart <alex.stewart@ni.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-future_0.16.0.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-future_0.16.0.bb b/meta-python/recipes-devtools/python/python-future_0.16.0.bb
new file mode 100644
index 0000000000..46f7fe50f6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-future_0.16.0.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "Clean single-source support for Python 3 and 2"
+HOMEPAGE = "https://python-future.org"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3f457538b297bd0ef86564b8ac216ad7"
+
+SRC_URI[md5sum] = "3e8e88a2bda48d54b1da7634d04760d7"
+SRC_URI[sha256sum] = "e39ced1ab767b5936646cedba8bcce582398233d6a627067d4c6a454c90cfedb"
+
+PYPI_PACKAGE_HASH = "99abde815842bc6e97d5a7806ad51236630da14ca2f3b1fce94c0bb94d3d"
+
+inherit pypi setuptools
+
+BBCLASSEXTEND = "native"