aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-11-01 12:40:18 -0400
committerArmin Kuster <akuster808@gmail.com>2017-11-15 16:31:30 -0800
commitbd827cb9ff57b8e42768add8e8b206c95cd6aea2 (patch)
tree0c7ad9686de36bd99c7ca2b620c8b689bc6be1e2 /meta-python
parent7b5e171914028727fb937753c8e5a9631585db67 (diff)
downloadmeta-openembedded-contrib-bd827cb9ff57b8e42768add8e8b206c95cd6aea2.tar.gz
python-attrs: add an initial recipe for version 17.2.0
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-attrs.inc9
-rw-r--r--meta-python/recipes-devtools/python/python-attrs_17.2.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-attrs_17.2.0.bb2
3 files changed, 13 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-attrs.inc b/meta-python/recipes-devtools/python/python-attrs.inc
new file mode 100644
index 0000000000..85073e979a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-attrs.inc
@@ -0,0 +1,9 @@
+DESCRIPTION = "Classes Without Boilerplate"
+HOMEPAGE = "http://www.attrs.org/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d4ab25949a73fe7d4fdee93bcbdbf8ff"
+
+SRC_URI[md5sum] = "3b7136a570f3ff8a4ff42e7360073f9f"
+SRC_URI[sha256sum] = "5d4d1b99f94d69338f485984127e4473b3ab9e20f43821b0e546cc3b2302fd11"
+
+inherit pypi
diff --git a/meta-python/recipes-devtools/python/python-attrs_17.2.0.bb b/meta-python/recipes-devtools/python/python-attrs_17.2.0.bb
new file mode 100644
index 0000000000..a6fdf158dc
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-attrs_17.2.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-attrs.inc
diff --git a/meta-python/recipes-devtools/python/python3-attrs_17.2.0.bb b/meta-python/recipes-devtools/python/python3-attrs_17.2.0.bb
new file mode 100644
index 0000000000..c34693f506
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-attrs_17.2.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-attrs.inc