aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2016-03-06 14:56:42 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2016-03-14 12:15:23 +0100
commit08b0d3967ec5c2a5427ebdd19fee42ebbe20bec5 (patch)
treef23730a5c9126fe9d99b14285ee3a9bff25886a3 /meta-python
parent7c43e026b1151e3c468fe8432dc1c35cd0122421 (diff)
downloadmeta-openembedded-contrib-08b0d3967ec5c2a5427ebdd19fee42ebbe20bec5.tar.gz
python-m2crypt: update package to 0.23.0
this happens to fix the cdra build issue related to the openssl 1.0.2g update. Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch35
-rw-r--r--meta-python/recipes-devtools/python/python-m2crypto_0.21.1.bb44
-rw-r--r--meta-python/recipes-devtools/python/python-m2crypto_0.23.0.bb30
3 files changed, 46 insertions, 63 deletions
diff --git a/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch b/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
index bcbdf24bb5..819c8e5697 100644
--- a/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
+++ b/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
@@ -10,30 +10,27 @@ Upstream-status: Unknown
setup.py | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
-diff --git a/setup.py b/setup.py
-index e7c49eb..8deaa34 100644
---- a/setup.py
-+++ b/setup.py
-@@ -40,7 +40,7 @@ class _M2CryptoBuildExt(build_ext.build_ext):
+Index: M2Crypto-0.23.0/setup.py
+===================================================================
+--- M2Crypto-0.23.0.orig/setup.py
++++ M2Crypto-0.23.0/setup.py
+@@ -62,7 +62,7 @@ class _M2CryptoBuildExt(build_ext.build_
self.openssl = 'c:\\pkg'
else:
self.libraries = ['ssl', 'crypto']
- self.openssl = '/usr'
+ self.openssl = os.environ.get( "STAGING_DIR" )
-
-
+
def finalize_options(self):
-@@ -49,8 +49,8 @@ class _M2CryptoBuildExt(build_ext.build_ext):
+ '''Overloaded build_ext implementation to append custom openssl
+@@ -75,8 +75,8 @@ class _M2CryptoBuildExt(build_ext.build_
+ if _openssl and os.path.isdir(_openssl):
+ self.openssl = _openssl
- build_ext.build_ext.finalize_options(self)
+- self.include_dirs.append(os.path.join(self.openssl, 'include'))
+- openssl_library_dir = os.path.join(self.openssl, 'lib')
++ self.include_dirs.append(os.environ.get( "STAGING_INCDIR" ))
++ openssl_library_dir = os.environ.get( "STAGING_LIBDIR" )
-- opensslIncludeDir = os.path.join(self.openssl, 'include')
-- opensslLibraryDir = os.path.join(self.openssl, 'lib')
-+ opensslIncludeDir = os.environ.get( "STAGING_INCDIR" )
-+ opensslLibraryDir = os.environ.get( "STAGING_LIBDIR" )
-
- self.swig_opts = ['-I%s' % i for i in self.include_dirs + \
- [opensslIncludeDir]]
---
-1.8.1.4
-
+ if platform.system() == "Linux":
+ if _multiarch: # on Fedora/RHEL it is an empty string
diff --git a/meta-python/recipes-devtools/python/python-m2crypto_0.21.1.bb b/meta-python/recipes-devtools/python/python-m2crypto_0.21.1.bb
deleted file mode 100644
index a3f9a09c6b..0000000000
--- a/meta-python/recipes-devtools/python/python-m2crypto_0.21.1.bb
+++ /dev/null
@@ -1,44 +0,0 @@
-SUMMARY = "A Python crypto and SSL toolkit"
-HOMEPAGE = "http://chandlerproject.org/bin/view/Projects/MeTooCrypto"
-
-DEPENDS = "openssl swig-native python"
-
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://LICENCE;md5=b0e1f0b7d0ce8a62c18b1287b991800e"
-
-SRC_URI = " \
- file://0001-setup.py-link-in-sysroot-not-in-host-directories.patch \
- file://0001-M2Crypto-Error-fix.patch"
-
-SRC_URI[md5sum] = "f93d8462ff7646397a9f77a2fe602d17"
-SRC_URI[sha256sum] = "25b94498505c2d800ee465db0cc1aff097b1615adc3ac042a1c85ceca264fc0a"
-
-PYPI_PACKAGE = "M2Crypto"
-inherit pypi setuptools
-
-SWIG_FEATURES_x86-64 = "-D__x86_64__"
-SWIG_FEATURES ?= ""
-export SWIG_FEATURES
-
-# Get around a problem with swig, but only if the
-# multilib header file exists.
-#
-do_compile_prepend() {
- if [ "${SITEINFO_BITS}" = "64" ];then
- bit="64"
- else
- bit="32"
- fi
-
- if [ -e ${STAGING_INCDIR}/openssl/opensslconf-${bit}.h ] ;then
- for i in SWIG/_ec.i SWIG/_evp.i; do
- sed -i -e "s/opensslconf.*\./opensslconf-${bit}\./" "$i"
- done
- elif [ -e ${STAGING_INCDIR}/openssl/opensslconf-n${bit}.h ] ;then
- for i in SWIG/_ec.i SWIG/_evp.i; do
- sed -i -e "s/opensslconf.*\./opensslconf-n${bit}\./" "$i"
- done
- fi
-}
-
-BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-devtools/python/python-m2crypto_0.23.0.bb b/meta-python/recipes-devtools/python/python-m2crypto_0.23.0.bb
new file mode 100644
index 0000000000..af8ca09545
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-m2crypto_0.23.0.bb
@@ -0,0 +1,30 @@
+SUMMARY = "A Python crypto and SSL toolkit"
+HOMEPAGE = "http://chandlerproject.org/bin/view/Projects/MeTooCrypto"
+
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=68f7880de949412b2ea248932d97ed54"
+
+SRCNAME = "M2Crypto"
+SRC_URI = "http://pypi.python.org/packages/source/M/M2Crypto/M2Crypto-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "89557730e245294a6cab06de8ad4fb42"
+SRC_URI[sha256sum] = "1ac3b6eafa5ff7e2a0796675316d7569b28aada45a7ab74042ad089d15a9567f"
+
+SRC_URI += "file://0001-setup.py-link-in-sysroot-not-in-host-directories.patch "
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools
+
+DEPENDS += "openssl swig-native"
+
+DISTUTILS_BUILD_ARGS += "build_ext --openssl=${STAGING_DIR_HOST} -I${STAGING_INCDIR}"
+DISTUTILS_INSTALL_ARGS += "build_ext --openssl=${STAGING_DIR_HOST}"
+
+inherit setuptools
+
+SWIG_FEATURES_x86-64 = "-D__x86_64__"
+SWIG_FEATURES ?= ""
+export SWIG_FEATURES
+
+BBCLASSEXTEND = "native"