aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorSven Ebenfeld <sven.ebenfeld@gmail.com>2016-01-22 23:24:34 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-02-01 15:51:16 +0100
commit1e049fbc1c771dface71a190600b2e63f5f4345c (patch)
tree0fc8327bf1f43d25ef1d70018b3102392c363069 /meta-python
parent816039cd96ba302477a7d784412873f28567f8f1 (diff)
downloadmeta-openembedded-contrib-1e049fbc1c771dface71a190600b2e63f5f4345c.tar.gz
python(3)-passlib: add recipes
Signed-off-by: Sven Ebenfeld <sven.ebenfeld@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-passlib.inc14
-rw-r--r--meta-python/recipes-devtools/python/python-passlib_1.6.5.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-passlib_1.6.5.bb2
3 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-passlib.inc b/meta-python/recipes-devtools/python/python-passlib.inc
new file mode 100644
index 0000000000..843e8e0675
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-passlib.inc
@@ -0,0 +1,14 @@
+SUMMARY = "comprehensive password hashing framework supporting over 30 schemes"
+DESCRIPTION = "\
+Passlib is a password hashing library for Python 2 & 3, which provides cross-platform \
+implementations of over 30 password hashing algorithms, as well as a framework for \
+managing existing password hashes. It’s designed to be useful for a wide range of \
+tasks, from verifying a hash found in /etc/shadow, to providing full-strength password \
+hashing for multi-user applications."
+HOMEPAGE = "https://bitbucket.org/ecollins/passlib"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=bae8faa3e2689ee0df3f2127fc4517f5"
+PR = "r0"
+
+SRC_URI[md5sum] = "d2edd6c42cde136a538b48d90a06ad67"
+SRC_URI[sha256sum] = "a83d34f53dc9b17aa42c9a35c3fbcc5120f3fcb07f7f8721ec45e6a27be347fc"
diff --git a/meta-python/recipes-devtools/python/python-passlib_1.6.5.bb b/meta-python/recipes-devtools/python/python-passlib_1.6.5.bb
new file mode 100644
index 0000000000..73ace94eb4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-passlib_1.6.5.bb
@@ -0,0 +1,2 @@
+inherit pypi
+require python-passlib.inc \ No newline at end of file
diff --git a/meta-python/recipes-devtools/python/python3-passlib_1.6.5.bb b/meta-python/recipes-devtools/python/python3-passlib_1.6.5.bb
new file mode 100644
index 0000000000..12718326e2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-passlib_1.6.5.bb
@@ -0,0 +1,2 @@
+inherit pypi3
+require python-passlib.inc \ No newline at end of file