aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-01-11 18:01:00 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2016-01-27 12:36:30 +0100
commit21492e2b769bab6607dd7410aa679e2981e77720 (patch)
tree1f9367a543144edaeb52fa154101914a133009eb /meta-python
parent669f87ad16a9d93141cb21bae302272d731d3b82 (diff)
downloadmeta-openembedded-contrib-21492e2b769bab6607dd7410aa679e2981e77720.tar.gz
python-jsonpointer: add recipe for 1.10
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-jsonpointer_1.10.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-jsonpointer_1.10.bb b/meta-python/recipes-devtools/python/python-jsonpointer_1.10.bb
new file mode 100644
index 0000000000..1af13a9281
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-jsonpointer_1.10.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Resolve JSON Pointers in Python"
+HOMEPAGE = "https://github.com/stefankoegl/python-json-pointer"
+SECTION = "devel/python"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=32b15c843b7a329130f4e266a281ebb3"
+
+SRCNAME = "jsonpointer"
+
+SRC_URI = " \
+ https://pypi.python.org/packages/source/j/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
+"
+
+inherit setuptools
+
+SRC_URI[md5sum] = "d68c0c6ad6889e9c94ec0feba719e45e"
+SRC_URI[sha256sum] = "9fa5dcac35eefd53e25d6cd4c310d963c9f0b897641772cd6e5e7b89df7ee0b1"
+
+RDEPENDS_${PN} += "python-re python-json"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"