aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-05-19 12:52:55 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2017-06-05 11:01:42 +0200
commit38d11cb2932e53a07b44c989fb5f54cb13cbd11f (patch)
tree242ebc087dd1484f3c5bdd5739e3506728541211 /meta-python
parent86b4cf5de56445561ab311464b8727c76420ebba (diff)
downloadmeta-openembedded-contrib-38d11cb2932e53a07b44c989fb5f54cb13cbd11f.tar.gz
python-zopeinterface: fixup test package
The recipe seems to have the intent of creating a 'tests' package but doesn't follow through on this intent. Rename 'tests' to 'test' to match other python test packages and follow through on the intent to actually produce a 'test' package. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-zopeinterface_4.3.3.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python-zopeinterface_4.3.3.bb b/meta-python/recipes-devtools/python/python-zopeinterface_4.3.3.bb
index 75963948fa..8ad1250822 100644
--- a/meta-python/recipes-devtools/python/python-zopeinterface_4.3.3.bb
+++ b/meta-python/recipes-devtools/python/python-zopeinterface_4.3.3.bb
@@ -8,11 +8,16 @@ SRC_URI[sha256sum] = "8780ef68ca8c3fe1abb30c058a59015129d6e04a6b02c2e56b9c7de607
PYPI_PACKAGE = "zope.interface"
inherit pypi setuptools
+PACKAGES =. "${PN}-test "
+
RPROVIDES_${PN} += "zope-interfaces"
+
+RDEPENDS_${PN}-test += "python-unittest python-doctest"
+
FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/*.egg/*/*/.debug"
FILES_${PN}-dev += "${PYTHON_SITEPACKAGES_DIR}/zope/interface/*.c"
FILES_${PN}-doc += "${PYTHON_SITEPACKAGES_DIR}/zope/interface/*.txt"
-FILES_${PN}-tests = " \
+FILES_${PN}-test += " \
${PYTHON_SITEPACKAGES_DIR}/zope/interface/tests \
${PYTHON_SITEPACKAGES_DIR}/zope/interface/common/tests \
"