aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorArmin Kuster <akuster@mvista.com>2016-03-23 14:53:03 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2016-03-25 11:27:33 +0100
commit44f0e74954628d6a3d04fa5249dbe0c94f6dff59 (patch)
tree2581a1289077aa804c5b093de1054a41427ca3e0 /meta-python
parent0e6e40696de199ddddaaae801ced016aea9dd722 (diff)
downloadmeta-openembedded-contrib-44f0e74954628d6a3d04fa5249dbe0c94f6dff59.tar.gz
python-crytograph: fix build issue do to openssl 1.0.1g upgrade
this fixes build/temp.linux-x86_64-2.7/_openssl.c:697:6: error: conflicting types for 'BIO_new_mem_buf' BIO *BIO_new_mem_buf(void *, int); ^ In file included from /home/jenkins/oe/world/shr-core/tmp-glibc/sysroots/qemuarm/usr/include/openssl/asn1.h:65:0, from build/temp.linux-x86_64-2.7/_openssl.c:413: Signed-off-by: Armin Kuster <akuster@mvista.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-cryptography/build_fix_openssl_1.0.1g.patch28
-rw-r--r--meta-python/recipes-devtools/python/python-cryptography_1.1.bb3
2 files changed, 30 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python-cryptography/build_fix_openssl_1.0.1g.patch b/meta-python/recipes-devtools/python/python-cryptography/build_fix_openssl_1.0.1g.patch
new file mode 100644
index 0000000000..d08994fe8d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-cryptography/build_fix_openssl_1.0.1g.patch
@@ -0,0 +1,28 @@
+build issue do to openssl 1.0.1g upgrade
+
+BIO *BIO_new_mem_buf(void *, int);
+ ^
+In file included from /home/jenkins/oe/world/shr-core/tmp-glibc/sysroots/qemuarm/usr/include/openssl/asn1.h:65:0,
+from build/temp.linux-x86_64-2.7/_openssl.c:413:
+
+
+Upstream-Status: Pending
+
+seems to be a known issue
+https://github.com/pyca/cryptography/issues/2750
+
+Signed-off-by: Armin Kuster <akuster@mvista.com>
+
+Index: src/_cffi_src/openssl/bio.py
+===================================================================
+--- a/src/_cffi_src/openssl/bio.py
++++ b/src/_cffi_src/openssl/bio.py
+@@ -99,7 +99,7 @@ BIO *BIO_pop(BIO *);
+ BIO *BIO_next(BIO *);
+ BIO *BIO_find_type(BIO *, int);
+ BIO_METHOD *BIO_s_mem(void);
+-BIO *BIO_new_mem_buf(void *, int);
++BIO *BIO_new_mem_buf(const void *, int);
+ BIO_METHOD *BIO_s_file(void);
+ BIO *BIO_new_file(const char *, const char *);
+ BIO *BIO_new_fp(FILE *, int);
diff --git a/meta-python/recipes-devtools/python/python-cryptography_1.1.bb b/meta-python/recipes-devtools/python/python-cryptography_1.1.bb
index ffc8fd9dcd..c501787af2 100644
--- a/meta-python/recipes-devtools/python/python-cryptography_1.1.bb
+++ b/meta-python/recipes-devtools/python/python-cryptography_1.1.bb
@@ -4,7 +4,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4"
DEPENDS += " python-cffi-native python-cffi python-enum34 python-six python-pyasn1"
SRCNAME = "cryptography"
-SRC_URI = "file://run-ptest"
+SRC_URI = "file://run-ptest \
+ file://build_fix_openssl_1.0.1g.patch"
SRC_URI[md5sum] = "dd06da41535184f48f2c8e8b74dd570f"
SRC_URI[sha256sum] = "059bc6428b1d0e2317f505698602642f1d8dda5b120ec573a59a430d8cb7a32d"