aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-01-11 18:00:59 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2016-01-27 12:36:30 +0100
commit669f87ad16a9d93141cb21bae302272d731d3b82 (patch)
tree2d1b583352753c88243cc00b43aa3a805d733ac9 /meta-python
parent9c51ca476efa6c14072df7012160cbc000827d1a (diff)
downloadmeta-openembedded-contrib-669f87ad16a9d93141cb21bae302272d731d3b82.tar.gz
python-jsonpatch: add recipe for 1.12
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-jsonpatch_1.12.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-jsonpatch_1.12.bb b/meta-python/recipes-devtools/python/python-jsonpatch_1.12.bb
new file mode 100644
index 0000000000..504bb99088
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-jsonpatch_1.12.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Appling JSON patches in Python 2.6+ and 3.x"
+HOMEPAGE = "https://github.com/stefankoegl/python-json-patch"
+SECTION = "devel/python"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=32b15c843b7a329130f4e266a281ebb3"
+
+SRCNAME = "jsonpatch"
+
+SRC_URI = " \
+ https://pypi.python.org/packages/source/j/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
+"
+
+inherit setuptools
+
+SRC_URI[md5sum] = "76ae3183db5f2a8f85dd7705e9b6f278"
+SRC_URI[sha256sum] = "2e1eb457f9c8dd5dae837ca93c0fe5bd2522c9d44b9b380fb1aab2ab4dec04b1"
+
+RDEPENDS_${PN} += "python-re python-json python-jsonpointer"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+