aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2016-08-22 16:01:23 -0300
committerMartin Jansa <Martin.Jansa@gmail.com>2016-09-05 13:27:37 +0200
commit7d5ec62fed0bd822b2d96f916b691359ec446226 (patch)
tree907aceca1f8b8374a4f141ea4136c6d9e127123e /meta-python
parentc4728e0f7b3c7ba5d218700ecb41e103d28e999e (diff)
downloadmeta-openembedded-contrib-7d5ec62fed0bd822b2d96f916b691359ec446226.tar.gz
python-iso8601: Extend recipe to support Python 3
- Add Python 3 recipe - Add native and nativesdk to BBCLASSEXTEND Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-iso8601.inc8
-rw-r--r--meta-python/recipes-devtools/python/python-iso8601_0.1.11.bb8
-rw-r--r--meta-python/recipes-devtools/python/python3-iso8601_0.1.11.bb2
3 files changed, 11 insertions, 7 deletions
diff --git a/meta-python/recipes-devtools/python/python-iso8601.inc b/meta-python/recipes-devtools/python/python-iso8601.inc
new file mode 100644
index 0000000000..dd4b83cc9d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-iso8601.inc
@@ -0,0 +1,8 @@
+SUMMARY = "Simple module to parse ISO 8601 dates"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b05625f2336fa024e8d57e65c6595844"
+
+SRC_URI[md5sum] = "b06d11cd14a64096f907086044f0fe38"
+SRC_URI[sha256sum] = "e8fb52f78880ae063336c94eb5b87b181e6a0cc33a6c008511bac9a6e980ef30"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-iso8601_0.1.11.bb b/meta-python/recipes-devtools/python/python-iso8601_0.1.11.bb
index 484cf1243e..c543cf9f97 100644
--- a/meta-python/recipes-devtools/python/python-iso8601_0.1.11.bb
+++ b/meta-python/recipes-devtools/python/python-iso8601_0.1.11.bb
@@ -1,8 +1,2 @@
-SUMMARY = "Simple module to parse ISO 8601 dates"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=b05625f2336fa024e8d57e65c6595844"
-
-SRC_URI[md5sum] = "b06d11cd14a64096f907086044f0fe38"
-SRC_URI[sha256sum] = "e8fb52f78880ae063336c94eb5b87b181e6a0cc33a6c008511bac9a6e980ef30"
-
inherit pypi setuptools
+require python-iso8601.inc
diff --git a/meta-python/recipes-devtools/python/python3-iso8601_0.1.11.bb b/meta-python/recipes-devtools/python/python3-iso8601_0.1.11.bb
new file mode 100644
index 0000000000..4a332b53bd
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-iso8601_0.1.11.bb
@@ -0,0 +1,2 @@
+inherit pypi setuptools3
+require python-iso8601.inc