aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorPascal Bach <pascal.bach@siemens.com>2017-04-21 15:20:16 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-04-26 20:13:29 +0200
commit850ab4df1679e675b26acec5442c9604ac04ebf4 (patch)
treee654808d48005c104b8d3fccac2e6d09b7f2f95c /meta-python
parent8c1c8c269b3e798cd410326ed6c4ff25bc7c290d (diff)
downloadmeta-openembedded-contrib-850ab4df1679e675b26acec5442c9604ac04ebf4.tar.gz
python3-pytest-runner: make available for both Python 2 & 3
Signed-off-by: Pascal Bach <pascal.bach@siemens.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pytest-runner.inc17
-rw-r--r--meta-python/recipes-devtools/python/python-pytest-runner_2.11.1.bb17
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-runner_2.11.1.bb2
3 files changed, 23 insertions, 13 deletions
diff --git a/meta-python/recipes-devtools/python/python-pytest-runner.inc b/meta-python/recipes-devtools/python/python-pytest-runner.inc
new file mode 100644
index 0000000000..85a8de1f50
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pytest-runner.inc
@@ -0,0 +1,17 @@
+SUMMARY = "Invoke py.test as distutils command with dependency resolution"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e38b971c2b4c33b978d1b9c9ece9ae63"
+
+SRC_URI[md5sum] = "bdb73eb18eca2727944a2dcf963c5a81"
+SRC_URI[sha256sum] = "983a31eab45e375240e250161a556163bc8d250edaba97960909338c273a89b3"
+
+
+inherit pypi
+
+DEPENDS += " \
+ ${PYTHON_PN}-setuptools-scm-native"
+
+RDEPENDS_${PN} = "${PYTHON_PN}-py ${PYTHON_PN}-setuptools ${PYTHON_PN}-argparse ${PYTHON_PN}-debugger ${PYTHON_PN}-json \
+ ${PYTHON_PN}-io"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-pytest-runner_2.11.1.bb b/meta-python/recipes-devtools/python/python-pytest-runner_2.11.1.bb
index 188ef2b3cc..0a5055cb37 100644
--- a/meta-python/recipes-devtools/python/python-pytest-runner_2.11.1.bb
+++ b/meta-python/recipes-devtools/python/python-pytest-runner_2.11.1.bb
@@ -1,14 +1,5 @@
-SUMMARY = "Invoke py.test as distutils command with dependency resolution"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=e38b971c2b4c33b978d1b9c9ece9ae63"
+inherit setuptools
+require python-pytest-runner.inc
-SRC_URI[md5sum] = "bdb73eb18eca2727944a2dcf963c5a81"
-SRC_URI[sha256sum] = "983a31eab45e375240e250161a556163bc8d250edaba97960909338c273a89b3"
-
-DEPENDS += " \
- python-setuptools-scm"
-
-RDEPENDS_${PN} = "python-py python-setuptools python-argparse python-debugger python-json \
- python-compiler python-io"
-
-inherit pypi setuptools
+# Dependency only exists for python2
+RDEPENDS_${PN} += "python-compiler"
diff --git a/meta-python/recipes-devtools/python/python3-pytest-runner_2.11.1.bb b/meta-python/recipes-devtools/python/python3-pytest-runner_2.11.1.bb
new file mode 100644
index 0000000000..df56ba6d47
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest-runner_2.11.1.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-pytest-runner.inc