aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-03-23 16:01:57 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2016-03-25 11:27:31 +0100
commit98bb1b77946d25fcd0a61bd4c127052cb48bac31 (patch)
tree00cb8d02a0841cdb09db856819c4bd8fe6cfeaef /meta-python
parentc62d205a8e4d82cf19636a4392a0d24c57eaa5ce (diff)
downloadmeta-openembedded-contrib-98bb1b77946d25fcd0a61bd4c127052cb48bac31.tar.gz
python-idna: update to release 2.1 and use common pypi
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-idna_2.1.bb11
-rw-r--r--meta-python/recipes-devtools/python/python-idna_git.bb22
2 files changed, 11 insertions, 22 deletions
diff --git a/meta-python/recipes-devtools/python/python-idna_2.1.bb b/meta-python/recipes-devtools/python/python-idna_2.1.bb
new file mode 100644
index 0000000000..90f47aea9e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-idna_2.1.bb
@@ -0,0 +1,11 @@
+SUMMARY = "Internationalised Domain Names in Applications"
+HOMEPAGE = "https://github.com/kjd/idna"
+LICENSE = "BSD-3-Clause & Python-2.0 & Unicode"
+LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=134bdad79491c37bdae32811572b4bc6"
+
+DEPENDS += "python-pip"
+
+SRC_URI[md5sum] = "f6473caa9c5e0cc1ad3fd5d04c3c114b"
+SRC_URI[sha256sum] = "ed36f281aebf3cd0797f163bb165d84c31507cedd15928b095b1675e2d04c676"
+
+inherit pypi setuptools
diff --git a/meta-python/recipes-devtools/python/python-idna_git.bb b/meta-python/recipes-devtools/python/python-idna_git.bb
deleted file mode 100644
index dcd91053de..0000000000
--- a/meta-python/recipes-devtools/python/python-idna_git.bb
+++ /dev/null
@@ -1,22 +0,0 @@
-SUMMARY = "Internationalised Domain Names in Applications"
-HOMEPAGE = "https://github.com/kjd/idna"
-SECTION = "devel/python"
-LICENSE = "BSD-3-Clause & Python-2.0 & Unicode"
-LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=c61e6ec7ab3da6b340d8d3a89c964ef2"
-
-PV = "2.0"
-SRCREV = "bb6e94c5b5525684d8ca010bf8ab42480c319e0a"
-
-SRCNAME = "idna"
-SRC_URI = "git://github.com/kjd/${SRCNAME}.git"
-
-S = "${WORKDIR}/git"
-
-inherit setuptools
-
-DEPENDS += " \
- python-pip \
- "
-
-RDEPENDS_${PN} += " \
- "