aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2016-10-06 15:58:07 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2016-10-21 18:20:43 +0200
commita7e7eccede498a9aeeaf040476d49fd943c8a974 (patch)
tree23ef2ec7ca291901a5d3578b01c3376c68ef8884 /meta-python
parent7f5236bda38821fd9826b5d96469511e9d28fa93 (diff)
downloadmeta-openembedded-contrib-a7e7eccede498a9aeeaf040476d49fd943c8a974.tar.gz
python-pybind11: add pybind11 for operability between C++11 and Python
Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pybind11.inc9
-rw-r--r--meta-python/recipes-devtools/python/python-pybind11_1.8.1.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pybind11_1.8.1.bb2
3 files changed, 13 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pybind11.inc b/meta-python/recipes-devtools/python/python-pybind11.inc
new file mode 100644
index 0000000000..e13f6a5767
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pybind11.inc
@@ -0,0 +1,9 @@
+SUMMARY = "Seamless operability between C++11 and Python"
+HOMEPAGE = "https://github.com/wjakob/pybind11"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=1e9383cd3e97753d7dd6067d079519ea"
+PR = "r0"
+
+SRC_URI = "https://pypi.python.org/packages/89/0b/f3a25633e49be5fae17ed2c7751c8106a08199db70e3c82e8cc043388ba9/pybind11-1.8.1.tar.gz"
+SRC_URI[md5sum] = "67845d8fd89a1c400dc7c61ccdee14d6"
+SRC_URI[sha256sum] = "358d4b7d8c38cd1dde66064178c6bbaaa2c479a44e67e642820fe0f329a4fff8"
diff --git a/meta-python/recipes-devtools/python/python-pybind11_1.8.1.bb b/meta-python/recipes-devtools/python/python-pybind11_1.8.1.bb
new file mode 100644
index 0000000000..e56743002e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pybind11_1.8.1.bb
@@ -0,0 +1,2 @@
+inherit pypi setuptools
+require python-pybind11.inc
diff --git a/meta-python/recipes-devtools/python/python3-pybind11_1.8.1.bb b/meta-python/recipes-devtools/python/python3-pybind11_1.8.1.bb
new file mode 100644
index 0000000000..355e28460e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pybind11_1.8.1.bb
@@ -0,0 +1,2 @@
+inherit pypi setuptools3
+require python-pybind11.inc