aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorSven Ebenfeld <sven.ebenfeld@gmail.com>2016-01-22 23:56:32 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-02-01 15:51:17 +0100
commitd5bb0a142052ffd51bf3281ba0997ad081f81086 (patch)
tree23351fe66d6a799173327c822279c95840be0824 /meta-python
parent9a5ab2a080258ed6b097eaa2e025a1dbf2c3d6fa (diff)
downloadmeta-openembedded-contrib-d5bb0a142052ffd51bf3281ba0997ad081f81086.tar.gz
python3-tornado: add recipe
Signed-off-by: Sven Ebenfeld <sven.ebenfeld@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-tornado.inc24
-rw-r--r--meta-python/recipes-devtools/python/python-tornado_4.3.bb37
-rw-r--r--meta-python/recipes-devtools/python/python3-tornado_4.3.bb2
3 files changed, 29 insertions, 34 deletions
diff --git a/meta-python/recipes-devtools/python/python-tornado.inc b/meta-python/recipes-devtools/python/python-tornado.inc
new file mode 100644
index 0000000000..679b7ba035
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-tornado.inc
@@ -0,0 +1,24 @@
+SUMMARY = "Tornado is an open source version of the scalable, non-blocking web server and tools that power FriendFeed."
+DESCRIPTION = "Tornado is a Python web framework and asynchronous networking library, originally developed at FriendFeed. \
+By using non-blocking network I/O, Tornado can scale to tens of thousands of open connections, making it ideal for long \
+polling, WebSockets, and other applications that require a long-lived connection to each user."
+HOMEPAGE = "http://www.tornadoweb.org/en/stable/"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://setup.py;startline=2;endline=15;md5=5ab7571a79ad62d0ca7aea308bac7560"
+
+SRC_URI[md5sum] = "d13a99dc0b60ba69f5f8ec1235e5b232"
+SRC_URI[sha256sum] = "c9c2d32593d16eedf2cec1b6a41893626a2649b40b21ca9c4cac4243bde2efbf"
+
+RDEPENDS_${PN} += "${PYTHON_PN}-compression ${PYTHON_PN}-numbers ${PYTHON_PN}-email ${PYTHON_PN}-subprocess \
+ ${PYTHON_PN}-pkgutil ${PYTHON_PN}-html ${PYTHON_PN}-json ${PYTHON_PN}-certifi"
+
+RDEPENDS_${PN}-test += "${PN} ${PYTHON_PN}-unittest"
+
+PACKAGES =+ "\
+ ${PN}-test \
+"
+
+FILES_${PN}-test = " \
+ ${libdir}/${PYTHON_DIR}/site-packages/${SRCNAME}/test \
+ ${libdir}/${PYTHON_DIR}/site-packages/${SRCNAME}/testing.py* \
+"
diff --git a/meta-python/recipes-devtools/python/python-tornado_4.3.bb b/meta-python/recipes-devtools/python/python-tornado_4.3.bb
index c107d6c450..5bbad50a9e 100644
--- a/meta-python/recipes-devtools/python/python-tornado_4.3.bb
+++ b/meta-python/recipes-devtools/python/python-tornado_4.3.bb
@@ -1,34 +1,3 @@
-SUMMARY = "Tornado is an open source version of the scalable, non-blocking web server and tools that power FriendFeed."
-DESCRIPTION = "Tornado is a Python web framework and asynchronous networking library, originally developed at FriendFeed. \
-By using non-blocking network I/O, Tornado can scale to tens of thousands of open connections, making it ideal for long \
-polling, WebSockets, and other applications that require a long-lived connection to each user."
-HOMEPAGE = "http://www.tornadoweb.org/en/stable/"
-
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://PKG-INFO;md5=65b6c818261e415f48f5463a232ad195"
-
-SRCNAME = "tornado"
-
-SRC_URI = " \
- https://pypi.python.org/packages/source/t/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
-"
-SRC_URI[md5sum] = "d13a99dc0b60ba69f5f8ec1235e5b232"
-SRC_URI[sha256sum] = "c9c2d32593d16eedf2cec1b6a41893626a2649b40b21ca9c4cac4243bde2efbf"
-
-inherit setuptools
-
-RDEPENDS_${PN} += "python-compression python-numbers python-email python-subprocess \
- python-pkgutil python-html python-json python-backports-ssl python-certifi"
-
-RDEPENDS_${PN}-test += "${PN} python-unittest"
-
-S = "${WORKDIR}/${SRCNAME}-${PV}"
-
-PACKAGES =+ "\
- ${PN}-test \
-"
-
-FILES_${PN}-test = " \
- ${libdir}/${PYTHON_DIR}/site-packages/${SRCNAME}/test \
- ${libdir}/${PYTHON_DIR}/site-packages/${SRCNAME}/testing.py* \
-"
+inherit pypi
+require python-tornado.inc
+RDEPENDS_${PN} += "${PYTHON_PN}-backports-ssl"
diff --git a/meta-python/recipes-devtools/python/python3-tornado_4.3.bb b/meta-python/recipes-devtools/python/python3-tornado_4.3.bb
new file mode 100644
index 0000000000..21a4300f2f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-tornado_4.3.bb
@@ -0,0 +1,2 @@
+inherit pypi3
+require python-tornado.inc