aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorMoritz Fischer <moritz.fischer@ettus.com>2017-06-01 09:42:54 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-06-12 06:56:24 +0200
commitdfc764f0c557df1c0097fa6360cfc8be4a92f447 (patch)
treeeefae3ba88904f2e7372b38d696fcdd5452045c8 /meta-python
parent464995dca63cc5ceb168f8a244a70d42d6513d5e (diff)
downloadmeta-openembedded-contrib-dfc764f0c557df1c0097fa6360cfc8be4a92f447.tar.gz
python-pyroute: Add support for python3
Extend recipe to support python3 Signed-off-by: Moritz Fischer <moritz.fischer@ettus.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pyroute2.inc26
-rw-r--r--meta-python/recipes-devtools/python/python-pyroute2_0.3.22.bb26
-rw-r--r--meta-python/recipes-devtools/python/python3-pyroute2_0.3.22.bb2
3 files changed, 30 insertions, 24 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyroute2.inc b/meta-python/recipes-devtools/python/python-pyroute2.inc
new file mode 100644
index 0000000000..da1d4cd9b4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyroute2.inc
@@ -0,0 +1,26 @@
+SUMMARY = "A pure Python netlink and Linux network configuration library"
+LICENSE = "GPLv2 & Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.GPL.v2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://LICENSE.Apache.v2;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRC_URI[md5sum] = "733adb362b6603c7269c0b3df3045a55"
+SRC_URI[sha256sum] = "5cdf44656cf623369f0cbf183d9d14a1a50ebdffbd50d4e30ffda62c0a05d7b3"
+
+SRC_URI += "file://import-simplejson-as-json.patch"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/python-pyroute2:"
+
+inherit pypi
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-distutils \
+ ${PYTHON_PN}-simplejson \
+ ${PYTHON_PN}-multiprocessing \
+ ${PYTHON_PN}-io ${PYTHON_PN}-pprint \
+ ${PYTHON_PN}-pickle \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-textutils \
+ ${PYTHON_PN}-subprocess \
+ ${PYTHON_PN}-netclient \
+"
diff --git a/meta-python/recipes-devtools/python/python-pyroute2_0.3.22.bb b/meta-python/recipes-devtools/python/python-pyroute2_0.3.22.bb
index 79d3bdd18e..7b9c8e0445 100644
--- a/meta-python/recipes-devtools/python/python-pyroute2_0.3.22.bb
+++ b/meta-python/recipes-devtools/python/python-pyroute2_0.3.22.bb
@@ -1,24 +1,2 @@
-SUMMARY = "A pure Python netlink and Linux network configuration library"
-LICENSE = "GPLv2 & Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE.GPL.v2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
- file://LICENSE.Apache.v2;md5=3b83ef96387f14655fc854ddc3c6bd57"
-
-SRC_URI[md5sum] = "733adb362b6603c7269c0b3df3045a55"
-SRC_URI[sha256sum] = "5cdf44656cf623369f0cbf183d9d14a1a50ebdffbd50d4e30ffda62c0a05d7b3"
-
-SRC_URI += "file://import-simplejson-as-json.patch"
-
-inherit pypi setuptools
-
-RDEPENDS_${PN} += "\
- python-distutils \
- python-simplejson \
- python-multiprocessing \
- python-io python-pprint \
- python-pickle \
- python-logging \
- python-threading \
- python-textutils \
- python-subprocess \
- python-netclient \
-"
+require python-pyroute2.inc
+inherit setuptools
diff --git a/meta-python/recipes-devtools/python/python3-pyroute2_0.3.22.bb b/meta-python/recipes-devtools/python/python3-pyroute2_0.3.22.bb
new file mode 100644
index 0000000000..a23e72c4ad
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyroute2_0.3.22.bb
@@ -0,0 +1,2 @@
+require python-pyroute2.inc
+inherit setuptools3