aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorS. Lockwood-Childs <sjl@vctlabs.com>2017-08-02 14:51:23 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-13 13:20:58 +0200
commit3a13b1b4e3cc0ad48fc096109029a1258982a3cf (patch)
tree69d87f3e55c869ab3ddfd93860567195c7fdc8ad /meta-python
parent2d78e2cfabb3f1bd38d8e298e52932685df7f863 (diff)
downloadmeta-openembedded-contrib-3a13b1b4e3cc0ad48fc096109029a1258982a3cf.tar.gz
python-pyusb: make recipe available as python3 version
Refactored existing python-pyusb recipe so that pyusb can also be built for python3. Signed-off-by: S. Lockwood-Childs <sjl@vctlabs.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pyusb.inc10
-rw-r--r--meta-python/recipes-devtools/python/python-pyusb_1.0.0b2.bb12
-rw-r--r--meta-python/recipes-devtools/python/python3-pyusb_1.0.0b2.bb2
3 files changed, 14 insertions, 10 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyusb.inc b/meta-python/recipes-devtools/python/python-pyusb.inc
new file mode 100644
index 0000000000..af20109641
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyusb.inc
@@ -0,0 +1,10 @@
+SUMMARY = "PyUSB provides USB access on the Python language"
+HOMEPAGE = "http://pyusb.sourceforge.net/"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=50d46bda6248a0b4a46a6d59a66ee08e"
+DEPENDS += "libusb1"
+
+SRC_URI[md5sum] = "bc12e83ff3ef1045d4306d13a9955fc1"
+SRC_URI[sha256sum] = "14ec66077bdcd6f1aa9e892a0a35a54bb3c1ec56aa740ead64349c18f0186d19"
+
+inherit pypi
diff --git a/meta-python/recipes-devtools/python/python-pyusb_1.0.0b2.bb b/meta-python/recipes-devtools/python/python-pyusb_1.0.0b2.bb
index d279abc400..bb73d9f784 100644
--- a/meta-python/recipes-devtools/python/python-pyusb_1.0.0b2.bb
+++ b/meta-python/recipes-devtools/python/python-pyusb_1.0.0b2.bb
@@ -1,10 +1,2 @@
-SUMMARY = "PyUSB provides USB access on the Python language"
-HOMEPAGE = "http://pyusb.sourceforge.net/"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=50d46bda6248a0b4a46a6d59a66ee08e"
-DEPENDS = "libusb1"
-
-SRC_URI[md5sum] = "bc12e83ff3ef1045d4306d13a9955fc1"
-SRC_URI[sha256sum] = "14ec66077bdcd6f1aa9e892a0a35a54bb3c1ec56aa740ead64349c18f0186d19"
-
-inherit pypi distutils
+inherit distutils
+require python-pyusb.inc
diff --git a/meta-python/recipes-devtools/python/python3-pyusb_1.0.0b2.bb b/meta-python/recipes-devtools/python/python3-pyusb_1.0.0b2.bb
new file mode 100644
index 0000000000..813e6f08cc
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyusb_1.0.0b2.bb
@@ -0,0 +1,2 @@
+inherit distutils3
+require python-pyusb.inc