aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorPascal Bach <pascal.bach@siemens.com>2017-09-12 18:24:32 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-09-18 10:16:24 +0200
commit12d09665bbee2825ed54cd4254a33235d2ca3e26 (patch)
tree0cef292ddc354bceba0c551097c728ad15197d1b /meta-python
parenta81773768f9ef1b76b010d6b5292b575235495f3 (diff)
downloadmeta-openembedded-contrib-12d09665bbee2825ed54cd4254a33235d2ca3e26.tar.gz
python-jsonschema, python3-jsonschema: add vcversioner-native dependency
If not added the setup.py will complain that it can't find vcversioner. The non native dependency is not working as the module is required during compilation not at runtime. Also the dependency is required for both the Python 2 and Python 3 version Signed-off-by: Pascal Bach <pascal.bach@siemens.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-jsonschema.inc2
-rw-r--r--meta-python/recipes-devtools/python/python3-jsonschema_2.6.0.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python-jsonschema.inc b/meta-python/recipes-devtools/python/python-jsonschema.inc
index 74933f58cd..db57c69a4c 100644
--- a/meta-python/recipes-devtools/python/python-jsonschema.inc
+++ b/meta-python/recipes-devtools/python/python-jsonschema.inc
@@ -5,6 +5,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=7a60a81c146ec25599a3e1dabb8610a8"
SRC_URI[md5sum] = "50c6b69a373a8b55ff1e0ec6e78f13f4"
SRC_URI[sha256sum] = "6ff5f3180870836cae40f06fa10419f557208175f13ad7bc26caa77beb1f6e02"
+DEPENDS += "${PYTHON_PN}-vcversioner-native"
+
RDEPENDS_${PN} += " \
${PYTHON_PN}-core \
${PYTHON_PN}-io \
diff --git a/meta-python/recipes-devtools/python/python3-jsonschema_2.6.0.bb b/meta-python/recipes-devtools/python/python3-jsonschema_2.6.0.bb
index 53b88396fe..5aaee682b6 100644
--- a/meta-python/recipes-devtools/python/python3-jsonschema_2.6.0.bb
+++ b/meta-python/recipes-devtools/python/python3-jsonschema_2.6.0.bb
@@ -1,8 +1,6 @@
inherit pypi setuptools3
require python-jsonschema.inc
-DEPENDS += "python3-vcversioner"
-
RDEPENDS_${PN} += " \
${PYTHON_PN}-misc \
"