aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2016-08-22 16:01:24 -0300
committerMartin Jansa <Martin.Jansa@gmail.com>2016-09-05 13:27:38 +0200
commit1d68defca0ddf4225da978bd7a2f36cee6cf89da (patch)
tree41bdd0ae397cb0a701bb20683e46b1a5fd748c58 /meta-python
parent7d5ec62fed0bd822b2d96f916b691359ec446226 (diff)
downloadmeta-openembedded-contrib-1d68defca0ddf4225da978bd7a2f36cee6cf89da.tar.gz
python-pretend: Extend recipe to support Python 3
- Add Python 3 recipe - Add native and nativesdk to BBCLASSEXTEND Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pretend.inc8
-rw-r--r--meta-python/recipes-devtools/python/python-pretend_1.0.8.bb8
-rw-r--r--meta-python/recipes-devtools/python/python3-pretend_1.0.8.bb2
3 files changed, 11 insertions, 7 deletions
diff --git a/meta-python/recipes-devtools/python/python-pretend.inc b/meta-python/recipes-devtools/python/python-pretend.inc
new file mode 100644
index 0000000000..2d21cc4a89
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pretend.inc
@@ -0,0 +1,8 @@
+SUMMARY = "A library for stubbing in Python"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=411780c0b7fa756753e94affeee5bc99"
+
+SRC_URI[md5sum] = "7147050a95c9f494248557b42b58ad79"
+SRC_URI[sha256sum] = "930f2c1e18503e8f8c403abe2e02166c4a881941745147e712cdd4f49f3fb964"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-pretend_1.0.8.bb b/meta-python/recipes-devtools/python/python-pretend_1.0.8.bb
index ddc7b623e4..73b8ed4d7c 100644
--- a/meta-python/recipes-devtools/python/python-pretend_1.0.8.bb
+++ b/meta-python/recipes-devtools/python/python-pretend_1.0.8.bb
@@ -1,8 +1,2 @@
-SUMMARY = "A library for stubbing in Python"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=411780c0b7fa756753e94affeee5bc99"
-
-SRC_URI[md5sum] = "7147050a95c9f494248557b42b58ad79"
-SRC_URI[sha256sum] = "930f2c1e18503e8f8c403abe2e02166c4a881941745147e712cdd4f49f3fb964"
-
inherit pypi setuptools
+require python-pretend.inc
diff --git a/meta-python/recipes-devtools/python/python3-pretend_1.0.8.bb b/meta-python/recipes-devtools/python/python3-pretend_1.0.8.bb
new file mode 100644
index 0000000000..9c5d8a8437
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pretend_1.0.8.bb
@@ -0,0 +1,2 @@
+inherit pypi setuptools3
+require python-pretend.inc