aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2016-10-31 23:10:38 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-11-22 13:59:36 +0100
commit6864b601046c71509d924d7e2dfe811109984dc0 (patch)
treed63067f0b30e1ae7311cb6633c9bf236d6019159 /meta-python
parent913d1ea5d1b6684f24566acf96b4930b678daf97 (diff)
downloadmeta-openembedded-contrib-6864b601046c71509d924d7e2dfe811109984dc0.tar.gz
python3-psutil: add python3 version of psutil
Split out common code to python-psutil.inc Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-psutil.inc10
-rw-r--r--meta-python/recipes-devtools/python/python-psutil_4.2.0.bb12
-rw-r--r--meta-python/recipes-devtools/python/python3-psutil_4.2.0.bb6
3 files changed, 19 insertions, 9 deletions
diff --git a/meta-python/recipes-devtools/python/python-psutil.inc b/meta-python/recipes-devtools/python/python-psutil.inc
new file mode 100644
index 0000000000..33573fca9b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-psutil.inc
@@ -0,0 +1,10 @@
+SUMMARY = "A cross-platform process and system utilities module for Python"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=0f02e99f7f3c9a7fe8ecfc5d44c2be62"
+
+SRC_URI[md5sum] = "713f259f917a0c26acfbb7e6ae632ef7"
+SRC_URI[sha256sum] = "544f013a0aea7199e07e3efe5627f5d4165179a04c66050b234cc3be2eca1ace"
+
+RDEPENDS_${PN} += " \
+ python-subprocess \
+"
diff --git a/meta-python/recipes-devtools/python/python-psutil_4.2.0.bb b/meta-python/recipes-devtools/python/python-psutil_4.2.0.bb
index a5703dadec..d718011e4b 100644
--- a/meta-python/recipes-devtools/python/python-psutil_4.2.0.bb
+++ b/meta-python/recipes-devtools/python/python-psutil_4.2.0.bb
@@ -1,12 +1,6 @@
-SUMMARY = "A cross-platform process and system utilities module for Python"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=0f02e99f7f3c9a7fe8ecfc5d44c2be62"
-
-SRC_URI[md5sum] = "713f259f917a0c26acfbb7e6ae632ef7"
-SRC_URI[sha256sum] = "544f013a0aea7199e07e3efe5627f5d4165179a04c66050b234cc3be2eca1ace"
+inherit pypi setuptools
+require python-psutil.inc
RDEPENDS_${PN} += " \
python-subprocess \
- "
-
-inherit pypi setuptools
+"
diff --git a/meta-python/recipes-devtools/python/python3-psutil_4.2.0.bb b/meta-python/recipes-devtools/python/python3-psutil_4.2.0.bb
new file mode 100644
index 0000000000..d95332cdc1
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-psutil_4.2.0.bb
@@ -0,0 +1,6 @@
+inherit pypi setuptools3
+require python-psutil.inc
+
+RDEPENDS_${PN} += " \
+ python3-subprocess \
+"