aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorRuben De Smet <ruben.de.smet@rubdos.be>2016-11-04 20:38:11 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-11-23 15:24:41 +0100
commit9a0f8dcbfb6b9312e57d0928df4cafd7e399b7db (patch)
tree1dfc7441acdf43a2f9df89a7e1142d2bc783f207 /meta-python
parent6d4cde463874cf46e3d3796569217936a13251d9 (diff)
downloadmeta-openembedded-contrib-9a0f8dcbfb6b9312e57d0928df4cafd7e399b7db.tar.gz
python-spidev: add recipe for version 3.2
A python module for interfacing with SPI Signed-off-by: Ruben De Smet <ruben.de.smet@rubdos.be> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-spidev.inc17
-rw-r--r--meta-python/recipes-devtools/python/python3-spidev_3.2.bb2
2 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-spidev.inc b/meta-python/recipes-devtools/python/python-spidev.inc
new file mode 100644
index 0000000000..1b93763d57
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-spidev.inc
@@ -0,0 +1,17 @@
+SUMMARY = "Python bindings for Linux SPI access through spidev"
+DESCRIPTION = "This project contains a python module for interfacing with SPI\
+devices from user space via the spidev linux kernel driver.\
+This is a modified version of the code originally found\
+[here](http://elk.informatik.fh-augsburg.de/da/da-49/trees/pyap7k/lang/py-spi)\
+All code is GPLv2 licensed unless explicitly stated otherwise."
+HOMEPAGE = "http://github.com/doceme/py-spidev"
+SECTION = "devel/python"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE.md;md5=54bdb9022ebb75ab68399cdaab97da60"
+SRCNAME = "spidev"
+
+SRC_URI[md5sum] = "f601676f1bb48b9aa3b3897f95216365"
+SRC_URI[sha256sum] = "09d2b5122f0dd79910713a11f9a0020f71537224bf829916def4fffc0ea59456"
+
+
+inherit pypi
diff --git a/meta-python/recipes-devtools/python/python3-spidev_3.2.bb b/meta-python/recipes-devtools/python/python3-spidev_3.2.bb
new file mode 100644
index 0000000000..610611e438
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-spidev_3.2.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-spidev.inc