aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-11-27 10:56:58 -0500
committerArmin Kuster <akuster808@gmail.com>2017-11-30 09:13:32 -0800
commitb9380153987d93096199308b6c0afccef154eae5 (patch)
tree92443d8edbadb2ced57b35fbe33ae506b419f9e1 /meta-python
parent9faa0acba89e8a4bec464d5f8fe865f6e439edb8 (diff)
downloadmeta-openembedded-contrib-b9380153987d93096199308b6c0afccef154eae5.tar.gz
python-grpcio: only modify the compiler arguments on the target build
The modification of the compiler flags causes issues with the native builds of the package: src/core/lib/surface/lame_client.cc: In function ‘grpc_channel* grpc_lame_client_channel_create(const char*, grpc_status_code, const char*)’: src/core/lib/surface/lame_client.cc:178:3: warning: ‘auto’ changes meaning in C++11; please remove it [-Wc++0x-compat] auto chand = reinterpret_cast<grpc_core::ChannelData *>(elem->channel_data); ^ src/core/lib/surface/lame_client.cc:178:8: error: ‘chand’ does not name a type auto chand = reinterpret_cast<grpc_core::ChannelData *>(elem->channel_data); Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-grpcio_1.7.0.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python-grpcio_1.7.0.bb b/meta-python/recipes-devtools/python/python-grpcio_1.7.0.bb
index 3ca7d5366b..a7df0a2da4 100644
--- a/meta-python/recipes-devtools/python/python-grpcio_1.7.0.bb
+++ b/meta-python/recipes-devtools/python/python-grpcio_1.7.0.bb
@@ -4,8 +4,8 @@ SECTION = "devel/python"
DEPENDS = "python-protobuf"
-SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch \
- "
+SRC_URI_append_class-target = " file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch "
+
RDEPENDS_${PN} = "python-enum34 \
python-futures \
python-protobuf \