aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorTrevor Gamblin <trevor.gamblin@windriver.com>2020-05-12 16:22:13 -0400
committerArmin Kuster <akuster808@gmail.com>2020-05-20 16:50:08 +0000
commit894d78881eb4e4f97ca74819af6bfeb87de8cc6b (patch)
treed6c2080eb4498e956c44f1a8bcc332113ea00dbd /meta-python
parent34614aa264bee53c848ca146e237e2825610544a (diff)
downloadmeta-openembedded-contrib-894d78881eb4e4f97ca74819af6bfeb87de8cc6b.tar.gz
python3-pytoml: add datetime and stringold to RDEPENDS
Error messages like the following are encountered if datetime and stringold are not in RDEPENDS for pytoml, so add them: |Python 3.8.2 (default, Apr 27 2020, 08:51:00) |[GCC 9.3.0] on linux |Type "help", "copyright", "credits" or "license" for more information. |>>> import pytoml |Traceback (most recent call last): |File "<stdin>", line 1, in <module> |File "/usr/lib64/python3.8/site-packages/pytoml/_init_.py", line 2, in <module> |from .parser import load, loads |File "/usr/lib64/python3.8/site-packages/pytoml/parser.py", line 3, in <module> |from .utils import rfc3339_re, parse_rfc3339_re |File "/usr/lib64/python3.8/site-packages/pytoml/utils.py", line 1, in <module> |import datetime |ModuleNotFoundError: No module named 'datetime' Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 75b3d7e7bf3ea451c633adc6906c0c1695359fff) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pytoml_0.1.21.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytoml_0.1.21.bb b/meta-python/recipes-devtools/python/python3-pytoml_0.1.21.bb
index b09005ec9e..1533a895f3 100644
--- a/meta-python/recipes-devtools/python/python3-pytoml_0.1.21.bb
+++ b/meta-python/recipes-devtools/python/python3-pytoml_0.1.21.bb
@@ -15,6 +15,11 @@ SRC_URI += " \
file://run-ptest \
"
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-stringold \
+ "
+
RDEPENDS_${PN}-ptest += " \
${PYTHON_PN}-pytest \
"