aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-06-22 20:41:46 -0700
committerKhem Raj <raj.khem@gmail.com>2021-06-24 12:54:18 -0700
commit9e456c6908d2579657674c7cb41934c24ddb9ef7 (patch)
tree60f086653bc54bf7b85654a27eedd94277dc6d75 /meta-python
parent0b19534f5e1cad8a272978ee8dfe9454220fe158 (diff)
downloadmeta-openembedded-contrib-9e456c6908d2579657674c7cb41934c24ddb9ef7.tar.gz
python3-execnet: Add ptests
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-execnet/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-execnet_1.9.0.bb15
2 files changed, 15 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-execnet/run-ptest b/meta-python/recipes-devtools/python/python3-execnet/run-ptest
new file mode 100644
index 0000000000..b63c4de0d9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-execnet/run-ptest
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
diff --git a/meta-python/recipes-devtools/python/python3-execnet_1.9.0.bb b/meta-python/recipes-devtools/python/python3-execnet_1.9.0.bb
index ec16e8884e..a7b156535d 100644
--- a/meta-python/recipes-devtools/python/python3-execnet_1.9.0.bb
+++ b/meta-python/recipes-devtools/python/python3-execnet_1.9.0.bb
@@ -6,13 +6,22 @@ HOMEPAGE = "https://execnet.readthedocs.io/en/latest/"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=772fcdaca14b378878d05c7d857e6c3e"
+DEPENDS += "python3-pip-native"
+
+SRC_URI += "file://run-ptest \
+ "
SRC_URI[sha256sum] = "8f694f3ba9cc92cab508b152dcfe322153975c29bda272e2fd7f3f00f36e47c5"
-DEPENDS += "python3-pip-native"
+inherit ptest pypi setuptools3
-inherit pypi setuptools3
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/testing/* ${D}${PTEST_PATH}/tests/
+}
-PACKAGECONFIG[testing] = ",,,python3-pre-commit"
+RDEPENDS_${PN}-ptest += "\
+ python3-pytest \
+"
RDEPENDS_${PN} += "python3-core python3-crypt python3-ctypes python3-fcntl python3-io python3-shell python3-threading"