aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorhasan.men <hasan.men@bosphorusiss.com>2020-11-17 17:04:09 +0300
committerKhem Raj <raj.khem@gmail.com>2020-11-23 13:00:54 -0800
commit121c94e3c318ce3bebd0c87930068bff3c28fba0 (patch)
tree834192e903c3aec190339a496fe137761c943d09 /meta-python
parent8083cfda4671db4c5eaddc7155f6d86818cb8bdc (diff)
downloadmeta-openembedded-contrib-121c94e3c318ce3bebd0c87930068bff3c28fba0.tar.gz
python3-jsonpath-rw: Add recipe for v1.4.0
Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-jsonpath-rw_1.4.0.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-jsonpath-rw_1.4.0.bb b/meta-python/recipes-devtools/python/python3-jsonpath-rw_1.4.0.bb
new file mode 100644
index 0000000000..54e1b646d5
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-jsonpath-rw_1.4.0.bb
@@ -0,0 +1,12 @@
+DESCRIPTION = "A robust and significantly extended implementation of JSONPath for Python"
+HOMEPAGE = "https://github.com/kennknowles/python-jsonpath-rw"
+SECTION = "devel/python"
+LICENSE = "BSD+"
+LIC_FILES_CHKSUM = "file://README.rst;md5=02384665f821c394981e0dd1faec9a7d"
+
+SRC_URI[md5sum] = "3a807e05c2c12158fc6bb0a402fd5778"
+SRC_URI[sha256sum] = "05c471281c45ae113f6103d1268ec7a4831a2e96aa80de45edc89b11fac4fbec"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += " python3-decorator"