aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd/conf/layer.conf
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-05-17 09:30:42 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2012-05-17 09:30:42 +0200
commit86321c31730f5d6159b93da8278c9e00a4c92b14 (patch)
tree8f20a41c83fd75a8ab077d7fa2d87240f04a6037 /meta-systemd/conf/layer.conf
parent690a67b2d75d0cd44a0004c5db40c7b6e952a106 (diff)
downloadmeta-openembedded-contrib-86321c31730f5d6159b93da8278c9e00a4c92b14.tar.gz
meta-systemd: add layer
This is where the systemd related recipes and appends are going to live Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-systemd/conf/layer.conf')
-rw-r--r--meta-systemd/conf/layer.conf28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-systemd/conf/layer.conf b/meta-systemd/conf/layer.conf
new file mode 100644
index 0000000000..d07d2aded0
--- /dev/null
+++ b/meta-systemd/conf/layer.conf
@@ -0,0 +1,28 @@
+# It really depends on order of the layers appearing in BBLAYERS
+# variable in toplevel bblayers.conf file, where bitbake will search
+# for .inc files and others where bitbake uses BBPATH since it will
+# search the directories from first to last as specified in BBPATH
+# Therefore if you want a given layer to be considered high priority
+# for the .inc and .conf etc. then consider it adding at the beginning
+# of BBPATH. For bblayers bitbake will use BBFILES_PRIORITY to resolve
+# the recipe contention so the order of directories in BBFILES does
+# not matter.
+
+# We have a conf and classes directory, append to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have a recipes directory, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "systemd-layer"
+BBFILE_PATTERN_systemd := "^${LAYERDIR}/"
+
+# Define the priority for recipes (.bb files) from this layer,
+# choosing carefully how this layer interacts with all of the
+# other layers.
+
+BBFILE_PRIORITY_systemd-layer = "7"
+
+SIGGEN_EXCLUDERECIPES_ABISAFE += " \
+ systemd-serialgetty \
+"