aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd/recipes-core/systemd/systemd_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-08-04 20:05:30 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-08-08 09:02:30 +0200
commit980b338fb5100ff4c779335a86f3d9450ea8c54a (patch)
tree1d6db1881f20819cbee0e8dcf9de37ad55478bd0 /meta-systemd/recipes-core/systemd/systemd_git.bb
parent3ce8db6d187b864fa59206d4efa93b8f952b534e (diff)
downloadmeta-openembedded-contrib-980b338fb5100ff4c779335a86f3d9450ea8c54a.tar.gz
systemd: Upgrade to 187 tag
Dont inherit vala not needed anymore Fix build for ppc64 Consider /lib64 and /usr/lib64 Some 64bit architectures chose lib64 instead of lib for default library dirnames. So we dig this from metadata vars base_libdir and libdir instead of hardcoding 'lib' ppc64 in OE uses lib64 for default libdir and this leaves lot of udev/systemd files unpackaged since 'lib' was hardcoded Additionally use --split-usr option since in OE-Core now we want to treat /usr mounted sepatately. Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-systemd/recipes-core/systemd/systemd_git.bb')
-rw-r--r--meta-systemd/recipes-core/systemd/systemd_git.bb15
1 files changed, 9 insertions, 6 deletions
diff --git a/meta-systemd/recipes-core/systemd/systemd_git.bb b/meta-systemd/recipes-core/systemd/systemd_git.bb
index 39b883a23b..5d1c28b319 100644
--- a/meta-systemd/recipes-core/systemd/systemd_git.bb
+++ b/meta-systemd/recipes-core/systemd/systemd_git.bb
@@ -19,18 +19,20 @@ inherit gitpkgv
PKGV = "v${GITPKGVTAG}"
PV = "git"
-PR = "r4"
+PR = "r5"
-inherit useradd pkgconfig autotools vala perlnative
+inherit useradd pkgconfig autotools perlnative
-SRCREV = "cd96b3b86abb4a88cac2722bdfb6e5d4413f6831"
+SRCREV = "3fd89536883ea9e24e69f28de0d11cd7cffb42ce"
SRC_URI = "git://anongit.freedesktop.org/systemd/systemd;protocol=git \
+ file://use-rootlibdir.patch \
file://gtk-doc.make \
file://touchscreen.rules \
file://modprobe.rules \
file://var-run.conf \
"
+
LDFLAGS_libc-uclibc_append = " -lrt"
S = "${WORKDIR}/git"
@@ -38,6 +40,9 @@ S = "${WORKDIR}/git"
SYSTEMDDISTRO ?= "debian"
SYSTEMDDISTRO_angstrom = "angstrom"
+CACHED_CONFIGUREVARS = "ac_cv_file__usr_share_pci_ids=no \
+ ac_cv_file__usr_share_hwdata_pci_ids=no \
+ ac_cv_file__usr_share_misc_pci_ids=yes"
# The gtk+ tools should get built as a separate recipe e.g. systemd-tools
EXTRA_OECONF = " --with-distro=${SYSTEMDDISTRO} \
--with-rootprefix=${base_prefix} \
@@ -50,11 +55,9 @@ EXTRA_OECONF = " --with-distro=${SYSTEMDDISTRO} \
--disable-coredump \
--disable-introspection \
--with-pci-ids-path=/usr/share/misc \
- ac_cv_file__usr_share_pci_ids=no \
- ac_cv_file__usr_share_hwdata_pci_ids=no \
- ac_cv_file__usr_share_misc_pci_ids=yes \
--disable-gtk-doc-html \
--disable-tcpwrap \
+ --enable-split-usr \
"
# There's no docbook-xsl-native, so for the xsltproc check to false