aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd/recipes-core/systemd
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-12-03 14:41:14 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2012-12-11 01:52:55 +0100
commit6f6b66780acf161407bbc9f46f74e31fe215939d (patch)
tree43975293cff9913038d01857e346dfc071aa5d57 /meta-systemd/recipes-core/systemd
parent76ef4020368c7f50e05f2989691d1b6c0499ad46 (diff)
downloadmeta-openembedded-contrib-6f6b66780acf161407bbc9f46f74e31fe215939d.tar.gz
systemd: reenable python and add python-systemd-journald
* we need inherit pythonnative to find right python-native Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-systemd/recipes-core/systemd')
-rw-r--r--meta-systemd/recipes-core/systemd/systemd_git.bb22
1 files changed, 15 insertions, 7 deletions
diff --git a/meta-systemd/recipes-core/systemd/systemd_git.bb b/meta-systemd/recipes-core/systemd/systemd_git.bb
index 51d3371576..341e85d0c2 100644
--- a/meta-systemd/recipes-core/systemd/systemd_git.bb
+++ b/meta-systemd/recipes-core/systemd/systemd_git.bb
@@ -19,9 +19,15 @@ inherit gitpkgv
PKGV = "v${GITPKGVTAG}"
PV = "git"
-PR = "r10"
+PR = "r11"
-inherit useradd pkgconfig autotools perlnative
+# need to export these variables for python-config to work
+export BUILD_SYS
+export HOST_SYS
+export STAGING_INCDIR
+export STAGING_LIBDIR
+
+inherit useradd pkgconfig autotools perlnative pythonnative python-dir
SRCREV = "4d92e078e9d7e9a9d346065ea5e4afbafbdadb48"
SRC_URI = "git://anongit.freedesktop.org/systemd/systemd;protocol=git \
@@ -67,7 +73,7 @@ EXTRA_OECONF = " --with-distro=${SYSTEMDDISTRO} \
--disable-tcpwrap \
--enable-split-usr \
--disable-microhttpd \
- --without-python \
+ --with-python \
"
# There's no docbook-xsl-native, so for the xsltproc check to false
@@ -107,7 +113,7 @@ python populate_packages_prepend (){
}
PACKAGES_DYNAMIC += "^lib(udev|gudev|systemd).*"
-PACKAGES =+ "${PN}-gui ${PN}-vconsole-setup ${PN}-initramfs ${PN}-analyze"
+PACKAGES =+ "${PN}-gui ${PN}-vconsole-setup ${PN}-initramfs ${PN}-analyze python-${PN}-journal"
USERADD_PACKAGES = "${PN}"
GROUPADD_PARAM_${PN} = "-r lock"
@@ -116,6 +122,9 @@ FILES_${PN}-analyze = "${bindir}/systemd-analyze"
RDEPENDS_${PN}-analyze = "python-dbus"
RRECOMMENDS_${PN}-analyze = "python-pycairo"
+FILES_python-${PN}-journal = "${PYTHON_SITEPACKAGES_DIR}/systemd/*.py* ${PYTHON_SITEPACKAGES_DIR}/systemd/*.so"
+RDEPENDS_python-${PN}-journal = "python-core"
+
FILES_${PN}-initramfs = "/init"
RDEPENDS_${PN}-initramfs = "${PN}"
@@ -168,9 +177,8 @@ FILES_${PN} = " ${base_bindir}/* \
${base_libdir}/udev/rules.d/73-seat-late.rules \
${base_libdir}/udev/rules.d/99-systemd.rules \
"
-
-FILES_${PN}-dbg += "${systemd_unitdir}/.debug ${systemd_unitdir}/*/.debug ${base_libdir}/security/.debug/"
-FILES_${PN}-dev += "${base_libdir}/security/*.la ${datadir}/dbus-1/interfaces/ ${sysconfdir}/rpm/macros.systemd"
+FILES_${PN}-dbg += "${systemd_unitdir}/.debug ${systemd_unitdir}/*/.debug ${base_libdir}/security/.debug/ ${PYTHON_SITEPACKAGES_DIR}/systemd/.debug/"
+FILES_${PN}-dev += "${base_libdir}/security/*.la ${datadir}/dbus-1/interfaces/ ${sysconfdir}/rpm/macros.systemd ${PYTHON_SITEPACKAGES_DIR}/systemd/*.la"
RDEPENDS_${PN} += "dbus-systemd udev-systemd"