aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2014-07-30 10:02:30 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-08-01 14:23:46 +0200
commit583d9dc3381176c3ef30667838ccf43475edb5b9 (patch)
treec077f49d9bf5cbf3d6570e53d53d79630e0c496a /meta-systemd
parent0e17f09a833d1c3a11f42af219ff4d4ae47d12f1 (diff)
downloadmeta-openembedded-contrib-583d9dc3381176c3ef30667838ccf43475edb5b9.tar.gz
portmap: fix FILESEXTRAPATHS
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-systemd')
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend b/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend
index 765f4b3285..f13b51187c 100644
--- a/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend
@@ -1,4 +1,4 @@
-FILESEXTRAPATHS := "${THISDIR}/${PN}"
+FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
inherit systemd
@@ -9,8 +9,8 @@ SYSTEMD_SERVICE_${PN} = "portmap.service"
SYSTEMD_AUTO_ENABLE = "disable"
SRC_URI_append = " file://portmap.service"
+
do_install_append() {
install -d ${D}${systemd_unitdir}/system
install -m 0644 ${WORKDIR}/portmap.service ${D}${systemd_unitdir}/system
}
-