aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2013-04-30 07:51:59 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-05-03 16:12:02 +0200
commite6c0911c9bb58cad327c5780a33b575e4cf265c0 (patch)
treeb70cbe38545ba3a0def5aa6fe905c0b59afa547e /meta-systemd
parentdef06e9e9aec30ad14020073d7c4a506e3408968 (diff)
downloadmeta-openembedded-contrib-e6c0911c9bb58cad327c5780a33b575e4cf265c0.tar.gz
dhcp: do not start dhclient by default on boot
* most of the time start fails: | root@overo:~# systemctl status dhclient.service | dhclient.service - Dynamic Host Configuration Protocol (DHCP) | Loaded: loaded (/lib/systemd/system/dhclient.service; enabled) | Active: failed (Result: resources) since Thu 2000-01-06 22:07:27 UTC; 15min ago | Process: 300 ExecStart=/sbin/dhclient -cf /etc/dhcp/dhclient.conf -q -lf /var/lib/dhcp/dhclient.leases $INTERFACES (code=exited, status=0/SUCCESS) | | Jan 06 22:07:27 overo systemd[1]: Starting Dynamic Host Configuration Proto..... | Jan 06 22:07:27 overo systemd[1]: PID file /var/run/dhclient.pid not readab...t. | Jan 06 22:07:27 overo systemd[1]: Failed to start Dynamic Host Configuratio...). * in cases it does not fail to start and we have a managing service (e.g networkmanager) two instances of dhclient are running Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-systemd')
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_4.2.5-P1.bbappend3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_4.2.5-P1.bbappend b/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_4.2.5-P1.bbappend
index 22d412a25d..e9e09d34d3 100644
--- a/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_4.2.5-P1.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_4.2.5-P1.bbappend
@@ -3,12 +3,13 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
inherit systemd
-PRINC := "${@int(PRINC) + 2}"
+PRINC := "${@int(PRINC) + 3}"
SYSTEMD_PACKAGES = "dhcp-server dhcp-relay dhcp-client"
SYSTEMD_SERVICE_dhcp-server = "dhcpd.service"
SYSTEMD_SERVICE_dhcp-relay = "dhcrelay.service"
SYSTEMD_SERVICE_dhcp-client = "dhclient.service"
+SYSTEMD_AUTO_ENABLE_dhcp-client = "disable"
FILES_dhcp-server += "${systemd_unitdir}/system/dhcpd.service"
FILES_dhcp-relay += "${systemd_unitdir}/system/dhrelay.service"