aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 13:45:37 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:22:03 +0200
commit4188d725513fb660348df16c290618dd0e6198ba (patch)
treeec2b40788f77222c04eb1124afcccb6af74a5ee3 /meta-systemd
parent9858cfdb4868ba7ed90d8e46784b7723c30e12c1 (diff)
downloadmeta-openembedded-contrib-4188d725513fb660348df16c290618dd0e6198ba.tar.gz
ntp: move systemd support from meta-systemd back to meta-networking
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-systemd')
-rw-r--r--meta-systemd/meta-networking/recipes-support/ntp/ntp/ntpd.service11
-rw-r--r--meta-systemd/meta-networking/recipes-support/ntp/ntp/ntpdate.service11
-rw-r--r--meta-systemd/meta-networking/recipes-support/ntp/ntp_4.2.6p5.bbappend28
3 files changed, 0 insertions, 50 deletions
diff --git a/meta-systemd/meta-networking/recipes-support/ntp/ntp/ntpd.service b/meta-systemd/meta-networking/recipes-support/ntp/ntp/ntpd.service
deleted file mode 100644
index bd87b1ea24..0000000000
--- a/meta-systemd/meta-networking/recipes-support/ntp/ntp/ntpd.service
+++ /dev/null
@@ -1,11 +0,0 @@
-[Unit]
-Description=Network Time Service
-After=network.target
-
-[Service]
-Type=forking
-PIDFile=/run/ntpd.pid
-ExecStart=/usr/bin/ntpd -p /run/ntpd.pid
-
-[Install]
-WantedBy=multi-user.target
diff --git a/meta-systemd/meta-networking/recipes-support/ntp/ntp/ntpdate.service b/meta-systemd/meta-networking/recipes-support/ntp/ntp/ntpdate.service
deleted file mode 100644
index 10cbd70f99..0000000000
--- a/meta-systemd/meta-networking/recipes-support/ntp/ntp/ntpdate.service
+++ /dev/null
@@ -1,11 +0,0 @@
-[Unit]
-Description=Network Time Service (one-shot ntpdate mode)
-Before=ntpd.service
-
-[Service]
-Type=oneshot
-ExecStart=/usr/bin/ntpdate-sync silent
-RemainAfterExit=yes
-
-[Install]
-WantedBy=multi-user.target
diff --git a/meta-systemd/meta-networking/recipes-support/ntp/ntp_4.2.6p5.bbappend b/meta-systemd/meta-networking/recipes-support/ntp/ntp_4.2.6p5.bbappend
deleted file mode 100644
index 7f2a796168..0000000000
--- a/meta-systemd/meta-networking/recipes-support/ntp/ntp_4.2.6p5.bbappend
+++ /dev/null
@@ -1,28 +0,0 @@
-inherit systemd
-
-PRINC := "${@int(PRINC) + 2}"
-
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
-SYSTEMD_PACKAGES = "${PN} ntpdate"
-SYSTEMD_SERVICE_${PN} = "ntpd.service"
-SYSTEMD_SERVICE_ntpdate = "ntpdate.service"
-RPROVIDES_${PN} += "${PN}-systemd"
-RREPLACES_${PN} += "${PN}-systemd"
-RCONFLICTS_${PN} += "${PN}-systemd"
-RPROVIDES_ntpdate += "ntpdate-systemd"
-RREPLACES_ntpdate += "ntpdate-systemd"
-RCONFLICTS_ntpdate += "ntpdate-systemd"
-
-FILES_ntpdate += "${systemd_unitdir}/system/ntpdate.service"
-
-SRC_URI += " \
- file://ntpdate.service \
- file://ntpd.service \
-"
-
-do_install_append() {
- install -d ${D}${systemd_unitdir}/system
- install -m 0644 ${WORKDIR}/ntpdate.service ${D}${systemd_unitdir}/system/
- install -m 0644 ${WORKDIR}/ntpd.service ${D}${systemd_unitdir}/system/
-}