aboutsummaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-httpd/apache2
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2013-09-25 10:34:23 +0800
committerPaul Eggleton <paul.eggleton@linux.intel.com>2013-09-26 09:35:56 +0100
commit0ffc5f7ae91d06fb8e1d71e0b7cd08b94cad9060 (patch)
tree535fca5b4002eb32de3ff9ce5b7a42076a163103 /meta-webserver/recipes-httpd/apache2
parent7e0bdfc5ecf7c551416e2a193c9220347d8fe03f (diff)
downloadmeta-openembedded-contrib-0ffc5f7ae91d06fb8e1d71e0b7cd08b94cad9060.tar.gz
apache2: fix error messages when restart apache service
There are error messages when restart apache service: Observed Behavior ====================== root@qemu0:/etc/php# apachectl restart AH00557: httpd: apr_sockaddr_info_get() failed for qemu0 AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1. Set the 'ServerName' directive globally to suppress this message root@qemu0:/etc/php# /etc/init.d/apache2 restart AH00557: httpd: apr_sockaddr_info_get() failed for qemu0 AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1. Set the 'ServerName' directive globally to suppress this message root@qemu0:/etc/php# /etc/init.d/apache2 stop AH00557: httpd: apr_sockaddr_info_get() failed for qemu0 AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1. Set the 'ServerName' directive globally to suppress this message Add 'ServerName localhost:80' to httpd.conf could fix this issue. Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Diffstat (limited to 'meta-webserver/recipes-httpd/apache2')
-rw-r--r--meta-webserver/recipes-httpd/apache2/apache2_2.4.6.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-webserver/recipes-httpd/apache2/apache2_2.4.6.bb b/meta-webserver/recipes-httpd/apache2/apache2_2.4.6.bb
index 6f5dd23bc4..c08175141f 100644
--- a/meta-webserver/recipes-httpd/apache2/apache2_2.4.6.bb
+++ b/meta-webserver/recipes-httpd/apache2/apache2_2.4.6.bb
@@ -73,6 +73,8 @@ do_install_append() {
printf "\nIncludeOptional ${sysconfdir}/${BPN}/modules.d/*.conf\n\n" >> ${D}/${sysconfdir}/${BPN}/httpd.conf
# match with that is in init script
printf "\nPidFile /run/httpd.pid" >> ${D}/${sysconfdir}/${BPN}/httpd.conf
+ # Set 'ServerName' to fix error messages when restart apache service
+ sed -i 's/^#ServerName www.example.com/ServerName localhost/' ${D}/${sysconfdir}/${BPN}/httpd.conf
if ${@base_contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -d ${D}${sysconfdir}/tmpfiles.d/