aboutsummaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-httpd/apache2
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-04-22 20:48:51 +0100
committerArmin Kuster <akuster808@gmail.com>2016-05-02 14:03:03 -0700
commit9078b0df2026fcf9d2ed287cb713b76907ae7087 (patch)
treee603cfb97abea31fef07a5e03dafc109b2721521 /meta-webserver/recipes-httpd/apache2
parentcf1819332d48d3307aa2e80255834aa7911cd0dc (diff)
downloadmeta-openembedded-contrib-9078b0df2026fcf9d2ed287cb713b76907ae7087.tar.gz
meta-webserver: use bb.utils.contains() instead of base_contains()
base_contains() is a compatibility wrapper and may warn in the future, so replace all instances with bb.utils.contains(). Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-webserver/recipes-httpd/apache2')
-rw-r--r--meta-webserver/recipes-httpd/apache2/apache2_2.4.20.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-webserver/recipes-httpd/apache2/apache2_2.4.20.bb b/meta-webserver/recipes-httpd/apache2/apache2_2.4.20.bb
index df2503421b..81151d1a47 100644
--- a/meta-webserver/recipes-httpd/apache2/apache2_2.4.20.bb
+++ b/meta-webserver/recipes-httpd/apache2/apache2_2.4.20.bb
@@ -57,7 +57,7 @@ EXTRA_OECONF = "--enable-ssl \
--enable-mpms-shared \
ac_cv_have_threadsafe_pollset=no"
-PACKAGECONFIG ?= "${@base_contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)}"
+PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)}"
PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux,libselinux"
PACKAGECONFIG[openldap] = "--enable-ldap --enable-authnz-ldap,--disable-ldap --disable-authnz-ldap,openldap"
@@ -86,7 +86,7 @@ do_install_append() {
# Set 'ServerName' to fix error messages when restart apache service
sed -i 's/^#ServerName www.example.com/ServerName localhost/' ${D}/${sysconfdir}/${BPN}/httpd.conf
- if ${@base_contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -d ${D}${sysconfdir}/tmpfiles.d/
install -m 0644 ${WORKDIR}/apache2-volatile.conf ${D}${sysconfdir}/tmpfiles.d/
fi