aboutsummaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-httpd/apache2
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2014-09-01 02:25:50 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2014-09-26 05:41:51 +0200
commitdf56eb34857748f6400ac04279194212356a94cb (patch)
treeece5c870916a0e43d57e775e8d44517c3a0d8843 /meta-webserver/recipes-httpd/apache2
parent054cef3654905b5d6e287117332c446ecedffb6d (diff)
downloadmeta-openembedded-contrib-df56eb34857748f6400ac04279194212356a94cb.tar.gz
apache2: split apache2-scripts subpkg
Split apache2-scripts subpkg to put the perl script dbmmanage, so that apache2 doesn't have to RDEPEND on perl. Add another perl script apxs to apache2-dev pkg as Olof Johansson suggested. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Diffstat (limited to 'meta-webserver/recipes-httpd/apache2')
-rw-r--r--meta-webserver/recipes-httpd/apache2/apache2_2.4.10.bb10
1 files changed, 8 insertions, 2 deletions
diff --git a/meta-webserver/recipes-httpd/apache2/apache2_2.4.10.bb b/meta-webserver/recipes-httpd/apache2/apache2_2.4.10.bb
index 035602934b..573cd6fb00 100644
--- a/meta-webserver/recipes-httpd/apache2/apache2_2.4.10.bb
+++ b/meta-webserver/recipes-httpd/apache2/apache2_2.4.10.bb
@@ -112,7 +112,7 @@ INITSCRIPT_NAME = "apache2"
INITSCRIPT_PARAMS = "defaults 91 20"
LEAD_SONAME = "libapr-1.so.0"
-PACKAGES = "${PN}-doc ${PN}-dev ${PN}-dbg ${PN}"
+PACKAGES = "${PN}-scripts ${PN}-doc ${PN}-dev ${PN}-dbg ${PN}"
CONFFILES_${PN} = "${sysconfdir}/${BPN}/httpd.conf \
${sysconfdir}/${BPN}/magic \
@@ -129,11 +129,16 @@ FILES_${PN}-dev = "${datadir}/${BPN}/build \
${libdir}/apr*.exp \
${includedir}/${BPN} \
${libdir}/*.la \
- ${libdir}/*.a"
+ ${libdir}/*.a \
+ ${bindir}/apxs \
+ "
+
# manual to manual
FILES_${PN}-doc += " ${datadir}/${BPN}/manual"
+FILES_${PN}-scripts += "${bindir}/dbmmanage"
+
#
# override this too - here is the default, less datadir
#
@@ -150,3 +155,4 @@ FILES_${PN} += "${libdir}/lib*.so ${libdir}/pkgconfig/*"
FILES_${PN}-dbg += "${libdir}/${BPN}/modules/.debug"
RDEPENDS_${PN} += "openssl libgcc"
+RDEPENDS_${PN}-scripts += "perl ${PN}"