aboutsummaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-httpd/apache2
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2015-11-20 15:39:48 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-12-18 12:39:50 +0100
commit00264bf4b3adad0cc2b083acbe23fdb3235c5874 (patch)
treef6a1ab4e641965358b9125e96b1e51238ee8e5f3 /meta-webserver/recipes-httpd/apache2
parente91bab37468e3bea5fc279f44ed1dbe1687f328a (diff)
downloadmeta-openembedded-contrib-00264bf4b3adad0cc2b083acbe23fdb3235c5874.tar.gz
apache2: fix host-user-contaminated warnings
It shows warnings when build apache2 such as: | WARNING: QA Issue: apache2: /apache2-dev/usr/share/apache2/icons/small/movie.gif | is owned by uid 1785, which is the same as the user running bitbake. | This may be due to host contamination [host-user-contaminated] Set the owner and group to root to fix it. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-webserver/recipes-httpd/apache2')
-rw-r--r--meta-webserver/recipes-httpd/apache2/apache2_2.4.16.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-webserver/recipes-httpd/apache2/apache2_2.4.16.bb b/meta-webserver/recipes-httpd/apache2/apache2_2.4.16.bb
index b62fd8c286..48c448ebdd 100644
--- a/meta-webserver/recipes-httpd/apache2/apache2_2.4.16.bb
+++ b/meta-webserver/recipes-httpd/apache2/apache2_2.4.16.bb
@@ -95,6 +95,8 @@ do_install_append() {
install -m 0644 ${WORKDIR}/apache2.service ${D}${systemd_unitdir}/system
sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/apache2.service
sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' ${D}${systemd_unitdir}/system/apache2.service
+
+ chown -R root:root ${D}
}
do_install_append_class-target() {