aboutsummaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-httpd/apache2
diff options
context:
space:
mode:
authorWenzong Fan <wenzong.fan@windriver.com>2015-09-30 01:49:03 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2015-10-13 12:28:14 +0200
commitac27acf362060b60fb025ea3578858f2bce62425 (patch)
tree7f59363f1c02fd45294f1f98d5ebb8d9ed3ca3c9 /meta-webserver/recipes-httpd/apache2
parentf2a41be9f09318c44b8d34b96fb6923d309616d9 (diff)
downloadmeta-openembedded-contrib-ac27acf362060b60fb025ea3578858f2bce62425.tar.gz
apache2: cleanup buildpaths for target stuffs
Those buildpaths were generated from configure substitutions, they are required for cross-compiling, but obviously they should be cleaned up from target stuffs. Cleanup buildpaths from config_vars.mk and config.nice: * remove ${STAGING_DIR_HOST} from CC, CFLAGS ... * set APU_INCLUDEDIR, APU_CONFIG as empty * remove buildpath from configure line Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-webserver/recipes-httpd/apache2')
-rw-r--r--meta-webserver/recipes-httpd/apache2/apache2_2.4.16.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta-webserver/recipes-httpd/apache2/apache2_2.4.16.bb b/meta-webserver/recipes-httpd/apache2/apache2_2.4.16.bb
index a44babdc6f..af5c72a5f5 100644
--- a/meta-webserver/recipes-httpd/apache2/apache2_2.4.16.bb
+++ b/meta-webserver/recipes-httpd/apache2/apache2_2.4.16.bb
@@ -97,6 +97,15 @@ do_install_append() {
sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' ${D}${systemd_unitdir}/system/apache2.service
}
+do_install_append_class-target() {
+ sed -i -e 's,${STAGING_DIR_HOST},,g' \
+ -e 's,APU_INCLUDEDIR = .*,APU_INCLUDEDIR = ,g' \
+ -e 's,APU_CONFIG = .*,APU_CONFIG = ,g' ${D}${datadir}/apache2/build/config_vars.mk
+
+ sed -i -e 's,${STAGING_DIR_HOST},,g' \
+ -e 's,".*/configure","configure",g' ${D}${datadir}/apache2/build/config.nice
+}
+
SYSROOT_PREPROCESS_FUNCS += "apache_sysroot_preprocess"
apache_sysroot_preprocess () {