aboutsummaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-httpd/cherokee/cherokee/cherokee-install-configured.py-once.patch
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2014-04-03 22:08:22 +0800
committerPaul Eggleton <paul.eggleton@linux.intel.com>2014-04-06 13:31:23 +0100
commit4b2a4dac0f19f1ba8a33b35b05be0808eca91b08 (patch)
tree593bb3d4ac601e3c2fa9b8bb006be249b82af786 /meta-webserver/recipes-httpd/cherokee/cherokee/cherokee-install-configured.py-once.patch
parenta60bf8c73adecf68d048c7725773d0772b22873e (diff)
downloadmeta-openembedded-contrib-4b2a4dac0f19f1ba8a33b35b05be0808eca91b08.tar.gz
cherokee: only install configured.py once
Both the two rules install-adminpyDATA and install-generatedDATA will install the configured.py to the same location, they can run parallel, and they use "install -m", which would might build failures: /usr/bin/install: setting permissions for `/path/to/configured.py': No such file or directory This is because the first install is setting the permission while the second install is removing the file an re-install. Only install the configured.py once will fix the problem, I think that there is no side effect since it installed the same file to the same location twice in the past. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Diffstat (limited to 'meta-webserver/recipes-httpd/cherokee/cherokee/cherokee-install-configured.py-once.patch')
-rw-r--r--meta-webserver/recipes-httpd/cherokee/cherokee/cherokee-install-configured.py-once.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-webserver/recipes-httpd/cherokee/cherokee/cherokee-install-configured.py-once.patch b/meta-webserver/recipes-httpd/cherokee/cherokee/cherokee-install-configured.py-once.patch
new file mode 100644
index 0000000000..3336f7df79
--- /dev/null
+++ b/meta-webserver/recipes-httpd/cherokee/cherokee/cherokee-install-configured.py-once.patch
@@ -0,0 +1,40 @@
+From 98a0f19df0a31d5649ad89d395fd1b8de5591827 Mon Sep 17 00:00:00 2001
+From: Robert Yang <liezhi.yang@windriver.com>
+Date: Thu, 3 Apr 2014 21:33:25 +0800
+Subject: [PATCH] admin/Makefile.am: only install configured.py once
+
+Both the two rules install-adminpyDATA and install-generatedDATA will
+install the configured.py to the same location, they can run parallel,
+and they use "install -m", which would might build failures:
+
+/usr/bin/install: setting permissions for `/path/to/configured.py': No such file or directory
+
+This is because the first install is setting the permission while the
+second install is removing the file an re-install.
+
+Only install the configured.py once will fix the problem, I think that
+there is no side effect since it installed the same file to the same
+location twice in the past.
+
+Upstream-Status: Pending
+
+Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
+---
+ admin/Makefile.am | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/admin/Makefile.am b/admin/Makefile.am
+index ce5937b..6f96934 100644
+--- a/admin/Makefile.am
++++ b/admin/Makefile.am
+@@ -73,7 +73,6 @@ SystemStatsWidgets.py \
+ Wizard.py \
+ XMLServerDigest.py \
+ config_version.py \
+-configured.py \
+ consts.py \
+ util.py \
+ popen.py \
+--
+1.8.2.1
+