aboutsummaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-httpd/hiawatha
diff options
context:
space:
mode:
authorJack Mitchell <jack.mitchell@dbbroadcast.co.uk>2013-04-18 11:20:20 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-22 09:51:47 +0200
commite1a4953e29ae1d605365b895d430ad622c605059 (patch)
tree4392bd79699d4ae387cddfd77e6679ccf062c8ae /meta-webserver/recipes-httpd/hiawatha
parent6b0aa8daf1bce02c9e40ae28d569132e0cac77fa (diff)
downloadmeta-openembedded-contrib-e1a4953e29ae1d605365b895d430ad622c605059.tar.gz
Hiawatha: update to 9.0, add systemd support
Signed-off-by: Jack Mitchell <jack.mitchell@dbbroadcast.co.uk> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-webserver/recipes-httpd/hiawatha')
-rw-r--r--meta-webserver/recipes-httpd/hiawatha/files/hiawatha.service16
-rw-r--r--meta-webserver/recipes-httpd/hiawatha/hiawatha_9.0.bb (renamed from meta-webserver/recipes-httpd/hiawatha/hiawatha_8.8.1.bb)19
2 files changed, 30 insertions, 5 deletions
diff --git a/meta-webserver/recipes-httpd/hiawatha/files/hiawatha.service b/meta-webserver/recipes-httpd/hiawatha/files/hiawatha.service
new file mode 100644
index 0000000000..26cb8d03d0
--- /dev/null
+++ b/meta-webserver/recipes-httpd/hiawatha/files/hiawatha.service
@@ -0,0 +1,16 @@
+[Unit]
+Description=Hiawatha Web Server
+After=network.target remote-fs.target nss-lookup.target
+
+[Service]
+Type=simple
+SyslogIdentifier=hiawatha
+ExecStartPre=/usr/sbin/hiawatha -k ; /usr/sbin/wigwam
+ExecStart= /usr/sbin/hiawatha -d
+TimeoutSec=10
+#(doesn't like this setting. Can't find files) PrivateTmp=true
+LimitNOFILE=infinity
+CapabilityBoundingSet=CAP_NET_BIND_SERVICE CAP_CHOWN CAP_DAC_OVERRIDE CAP_FOWNER CAP_FSETID CAP_SETGID CAP_SETUID
+
+[Install]
+WantedBy=multi-user.target
diff --git a/meta-webserver/recipes-httpd/hiawatha/hiawatha_8.8.1.bb b/meta-webserver/recipes-httpd/hiawatha/hiawatha_9.0.bb
index a7299708d6..ac2155813f 100644
--- a/meta-webserver/recipes-httpd/hiawatha/hiawatha_8.8.1.bb
+++ b/meta-webserver/recipes-httpd/hiawatha/hiawatha_9.0.bb
@@ -7,16 +7,19 @@ DEPENDS = "libxml2 libxslt"
SECTION = "net"
SRC_URI = "http://hiawatha-webserver.org/files/${PN}-${PV}.tar.gz \
- file://hiawatha-init "
+ file://hiawatha-init \
+ file://hiawatha.service "
-SRC_URI[md5sum] = "5def93779bbc10a021796abd3609caf7"
-SRC_URI[sha256sum] = "2583d8e7f48ddc6cdedc27bb51d3e130679fc2f4411622bae9ddce3ef965d063"
-
-inherit cmake update-rc.d
+SRC_URI[md5sum] = "8abc4f85dbb9a76ed66e7f35de520064"
+SRC_URI[sha256sum] = "5e40119afb050b11737250c08d89ac7ba7472645738a48c06aa79979a19729fc"
INITSCRIPT_NAME = "hiawatha"
INITSCRIPT_PARAMS = "defaults 70"
+SYSTEMD_SERVICE_${PN} = "hiawatha.service"
+
+inherit cmake update-rc.d systemd
+
EXTRA_OECMAKE = " -DENABLE_IPV6=OFF \
-DENABLE_CACHE=OFF \
-DENABLE_DEBUG=OFF \
@@ -44,6 +47,12 @@ do_install_append() {
# configure php-fcgi to have a working configuration
# by default if php is installed
echo "Server = ${bindir}/php-cgi ; 2 ; 127.0.0.1:2005 ; nobody:nobody ; ${sysconfdir}/php/hiawatha-php5/php.ini" >> ${D}${sysconfdir}/hiawatha/php-fcgi.conf
+
+ if ${@base_contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ install -d ${D}/${systemd_unitdir}/system
+ install -m 644 ${WORKDIR}/hiawatha.service ${D}/${systemd_unitdir}/system
+ fi
+
}
CONFFILES_${PN} = " \