aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-extended/imsettings/imsettings/gtk-is-required-by-notify.patch
diff options
context:
space:
mode:
authorHuang Qiyu <huangqy.fnst@cn.fujitsu.com>2018-02-09 13:11:07 +0800
committerArmin Kuster <akuster808@gmail.com>2018-02-11 13:39:50 -0800
commit6e833257b3bb702a9f64a0e4ad3f7868fa3896d8 (patch)
treee18b4d198612a2a209fdeafa4803dfcdf67d12b0 /meta-xfce/recipes-extended/imsettings/imsettings/gtk-is-required-by-notify.patch
parent09a106bd72c7cc8e6677723de21763767ebe185c (diff)
downloadmeta-openembedded-contrib-6e833257b3bb702a9f64a0e4ad3f7868fa3896d8.tar.gz
meta-openembedded-contrib-6e833257b3bb702a9f64a0e4ad3f7868fa3896d8.tar.bz2
meta-openembedded-contrib-6e833257b3bb702a9f64a0e4ad3f7868fa3896d8.zip
imsettings: 1.7.2 -> 1.7.3
1.Upgrade imsettings from 1.7.2 to 1.7.3. 2.Delete 0001-Rename-use-of-stdout-and-stderr.patch, gtk-is-required-by-notify.patch, multi-line-ACLOCAL_AMFLAGS-isnot-supported-by-autoreconf.patch, since it is integrated upstream. Signed-off-by: Huang Qiyu <huangqy.fnst@cn.fujitsu.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-xfce/recipes-extended/imsettings/imsettings/gtk-is-required-by-notify.patch')
-rw-r--r--meta-xfce/recipes-extended/imsettings/imsettings/gtk-is-required-by-notify.patch18
1 files changed, 0 insertions, 18 deletions
diff --git a/meta-xfce/recipes-extended/imsettings/imsettings/gtk-is-required-by-notify.patch b/meta-xfce/recipes-extended/imsettings/imsettings/gtk-is-required-by-notify.patch
deleted file mode 100644
index d42358d690..0000000000
--- a/meta-xfce/recipes-extended/imsettings/imsettings/gtk-is-required-by-notify.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-gtk+ is required by linnotify. So make sure gtk be linked before libnotify
-
-Signed-off-by: Bian Naimeng <biannm@cn.fujitsu.com>
-
-diff -Nurp imsettings-1.6.7.orig/configure.ac imsettings-1.6.7/configure.ac
---- imsettings-1.6.7.orig/configure.ac 2013-11-26 16:09:09.000000000 +0800
-+++ imsettings-1.6.7/configure.ac 2014-12-30 11:27:44.370003209 +0800
-@@ -93,8 +93,8 @@ PKG_CHECK_MODULES(LIBNOTIFY, libnotify,
- has_old_libnotify=yes
- PKG_CHECK_MODULES(GTK, gtk+-2.0 >= $GTK_REQUIRED)
- AC_DEFINE(HAS_OLD_LIBNOTIFY,, [Using older libnotify])
-- IMDAEMON_CFLAGS="$GTK_CFLAGS $LIBNOTIFY_OLD_CFLAGS"
-- IMDAEMON_LIBS="$GTK_LIBS $LIBNOTIFY_OLD_LIBS"],[
-+ IMDAEMON_CFLAGS="$LIBNOTIFY_OLD_CFLAGS $GTK_CFLAGS"
-+ IMDAEMON_LIBS="$LIBNOTIFY_OLD_LIBS $GTK_LIBS"],[
- has_old_libnotify=no
- IMDAEMON_CFLAGS="$LIBNOTIFY_CFLAGS"
- IMDAEMON_LIBS="$LIBNOTIFY_LIBS"])