aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-xfce/xfce4-panel
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-10-28 13:49:59 +0000
committerPaul Eggleton <paul.eggleton@linux.intel.com>2012-10-28 14:32:06 +0000
commit3a30c562385cb3d9cd1b3043f6fe677a22024018 (patch)
tree66dc67f338ba316c25ca672950ef334e9e357386 /meta-xfce/recipes-xfce/xfce4-panel
parentd66c9a8b625f7b19f7b17e728dc82413399c2e19 (diff)
downloadmeta-openembedded-contrib-3a30c562385cb3d9cd1b3043f6fe677a22024018.tar.gz
Replace bb.data.* with d.*
Used sed expression given here: http://lists.linuxtogo.org/pipermail/openembedded-core/2011-November/012373.html Plus an additional expression for .expand. Full expression is: sed \ -e 's:bb.data.\(setVar([^,]*,[^,]*\), \([^ )]*\) *):\2.\1):g' \ -e 's:bb.data.\(setVarFlag([^,]*,[^,]*,[^,]*\), \([^) ]*\) *):\2.\1):g' \ -e 's:bb.data.\(getVar([^,]*\), \([^, ]*\) *,\([^)]*\)):\2.\1,\3):g' \ -e 's:bb.data.\(getVarFlag([^,]*,[^,]*\), \([^, ]*\) *,\([^)]*\)):\2.\1,\3):g' \ -e 's:bb.data.\(getVarFlag([^,]*,[^,]*\), \([^) ]*\) *):\2.\1):g' \ -e 's:bb.data.\(getVar([^,]*\), \([^) ]*\) *):\2.\1):g' \ -e 's:bb.data.\(expand([^,]*\), \([^ )]*\) *):\2.\1):g' \ -i `grep -ril bb.data *` Some minor correction in systemd.bbclass was needed for some expressions that didn't quite match the regex in the desired way; additionally a few instances were manually changed. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-xfce/recipes-xfce/xfce4-panel')
-rw-r--r--meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.10.0.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.10.0.bb b/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.10.0.bb
index bb914ba8d7..f7d7c46874 100644
--- a/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.10.0.bb
+++ b/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.10.0.bb
@@ -10,8 +10,8 @@ SRC_URI[md5sum] = "cf7351a4b952dbe3fc5ff509c68def33"
SRC_URI[sha256sum] = "3321f998af2bbd14ba68654a8881774f6ea2ec4f1a3544598e7f47d3ed0009b9"
python populate_packages_prepend() {
- plugin_dir = bb.data.expand('${libdir}/xfce4/panel/plugins/', d)
- plugin_name = bb.data.expand('${PN}-plugin-%s', d)
+ plugin_dir = d.expand('${libdir}/xfce4/panel/plugins/')
+ plugin_name = d.expand('${PN}-plugin-%s')
do_split_packages(d, plugin_dir, '^lib(.*).so$', plugin_name,
'${PN} plugin for %s', extra_depends='', prepend=True,
aux_files_pattern=['${datadir}/xfce4/panel/plugins/%s.desktop',