aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-xfce/xfce4-panel
diff options
context:
space:
mode:
authorAndreas Mueller <schnitzeltony@gmx.de>2011-08-01 17:30:55 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-08-05 19:49:58 +0200
commit444901da61e3b08406fc048d000276edaa04e665 (patch)
treee2ed84317ac4735cc38d66d5be8c84452cff7c06 /meta-xfce/recipes-xfce/xfce4-panel
parent68b9b715d15b5cce58d6dfa479e18081a1d5faa0 (diff)
downloadmeta-openembedded-contrib-444901da61e3b08406fc048d000276edaa04e665.tar.gz
xfce4-panel: Add initial recipe with version 4.8.5
Diffstat (limited to 'meta-xfce/recipes-xfce/xfce4-panel')
-rw-r--r--meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.8.5.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.8.5.bb b/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.8.5.bb
new file mode 100644
index 0000000000..d99f3325ac
--- /dev/null
+++ b/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.8.5.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "Xfce4 Panel"
+SECTION = "x11"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=26a8bd75d8f8498bdbbe64a27791d4ee"
+DEPENDS = "libxfce4util garcon libxfce4ui xfconf exo gtk+ dbus cairo virtual/libx11 libxml2 libwnck"
+
+PR = "r0"
+
+inherit xfce
+
+python populate_packages_prepend() {
+ plugin_dir = bb.data.expand('${libdir}/xfce4/panel/plugins/', d)
+ plugin_name = bb.data.expand('${PN}-plugin-%s', d)
+ do_split_packages(d, plugin_dir, '^lib(.*).so$', plugin_name,
+ '${PN} plugin for %s', extra_depends='', prepend=True,
+ aux_files_pattern=['${datadir}/xfce4/panel/plugins/%s.desktop',
+ '${sysconfdir}/xdg/xfce/panel/%s-*',
+ '${datadir}/icons/hicolor/48x48/apps/*-%s.png',
+ '${bindir}/*%s*'])
+}
+
+PACKAGES_DYNAMIC = "${PN}-plugin-*"
+
+FILES_${PN} += "${libdir}/xfce4/panel/migrate \
+ ${libdir}/xfce4/panel/wrapper"
+
+FILES_${PN}-dbg += "${libdir}/xfce4/panel/plugins/.debug \
+ "
+
+FILES_${PN}-dev += "${libdir}/xfce4/panel/plugins/*.*a \
+ "
+
+SRC_URI[md5sum] = "3c00e92821709baa2a71b166a32d46a2"
+SRC_URI[sha256sum] = "df8379a18d337481b847cf232eec907a927287917788e7b730deef4a535deada"