aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce
diff options
context:
space:
mode:
authorAndreas Mueller <schnitzeltony@gmx.de>2011-08-01 17:43:34 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-08-05 19:49:58 +0200
commit336dbe95b80cf7bf13827ddd5a9ce02849a24aa7 (patch)
tree9b7cae74be090a4cea36ba5df314dfdcd25cb361 /meta-xfce
parent88c2a098d23161d270c80de859b060713b5f6456 (diff)
downloadmeta-openembedded-contrib-336dbe95b80cf7bf13827ddd5a9ce02849a24aa7.tar.gz
xfwm4: Add initial recipe with version 4.8.1
* xfwm4 must be started once manually to work
Diffstat (limited to 'meta-xfce')
-rw-r--r--meta-xfce/recipes-xfce/xfwm4/xfwm4/relative-symlinks-docs.patch28
-rw-r--r--meta-xfce/recipes-xfce/xfwm4/xfwm4_4.8.1.bb37
2 files changed, 65 insertions, 0 deletions
diff --git a/meta-xfce/recipes-xfce/xfwm4/xfwm4/relative-symlinks-docs.patch b/meta-xfce/recipes-xfce/xfwm4/xfwm4/relative-symlinks-docs.patch
new file mode 100644
index 0000000000..4e855e4f0f
--- /dev/null
+++ b/meta-xfce/recipes-xfce/xfwm4/xfwm4/relative-symlinks-docs.patch
@@ -0,0 +1,28 @@
+From 09d0d36450e25554785bf7f730e4ba0e31982be6 Mon Sep 17 00:00:00 2001
+From: Andreas Mueller <schnitzeltony@gmx.de>
+Date: Thu, 21 Jul 2011 19:52:28 +0200
+Subject: [PATCH] docs: On installation create relative paths in symlinks to
+ images
+
+
+Signed-off-by: Andreas Mueller <schnitzeltony@gmx.de>
+---
+ doc/manual/Makefile.am | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/doc/manual/Makefile.am b/doc/manual/Makefile.am
+index b21962f..88e234b 100644
+--- a/doc/manual/Makefile.am
++++ b/doc/manual/Makefile.am
+@@ -20,7 +20,7 @@ install-data-local:
+ done; \
+ if test x"$$lang" != x"C" -a ! -d $(srcdir)/images/$$lang; then \
+ echo "--- Creating symlink to C images for $$lang"; \
+- ln -sf $(docdir)/html/C/images $(DESTDIR)$(docdir)/html/$$lang/images; \
++ ln -sf ../C/images $(DESTDIR)$(docdir)/html/$$lang/images; \
+ fi \
+ fi \
+ done;
+--
+1.7.4.4
+
diff --git a/meta-xfce/recipes-xfce/xfwm4/xfwm4_4.8.1.bb b/meta-xfce/recipes-xfce/xfwm4/xfwm4_4.8.1.bb
new file mode 100644
index 0000000000..e31471d69a
--- /dev/null
+++ b/meta-xfce/recipes-xfce/xfwm4/xfwm4_4.8.1.bb
@@ -0,0 +1,37 @@
+DESCRIPTION="Xfce4 Window Manager"
+SECTION = "x11/wm"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d791728a073bc009b4ffaf00b7599855"
+DEPENDS = "virtual/libx11 libxpm gtk+ libxfce4util libxfce4ui xfconf libwnck dbus-glib startup-notification"
+RDEPENDS_${PN} = "xfwm4-theme-default"
+
+PR = "r0"
+
+inherit xfce update-alternatives
+
+# SRC_URI must follow inherited one
+SRC_URI += " \
+ file://relative-symlinks-docs.patch \
+"
+
+EXTRA_OECONF += " --enable-startup-notification"
+
+python populate_packages_prepend () {
+ themedir = bb.data.expand('${datadir}/themes', d)
+ do_split_packages(d, themedir, '^(.*)', 'xfwm4-theme-%s', 'XFWM4 theme %s', allow_dirs=True)
+}
+
+PACKAGES_DYNAMIC += "xfwm4-theme-*"
+
+ALTERNATIVE_NAME = "x-window-manager"
+ALTERNATIVE_LINK = "${bindir}/x-window-manager"
+ALTERNATIVE_PATH = "${bindir}/xfce4-session"
+ALTERNATIVE_PRIORITY = "30"
+
+FILES_${PN} += "${libdir}/xfce4/xfwm4/helper-dialog \
+ ${datadir}/xfwm4/defaults \
+ "
+FILES_${PN}-dbg += "${libexecdir}/xfce4/xfwm4/.debug/*"
+
+SRC_URI[md5sum] = "447433dca613180ebd6cfed4beb1c1c9"
+SRC_URI[sha256sum] = "6a3cbf6c92a0cc3bcaf7cf2565c35beae6354768ec26b4d616a3c2544a8f8499"