aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce
diff options
context:
space:
mode:
authorRobert Joslyn <robert.joslyn@redrectangle.org>2019-06-05 22:39:29 -0700
committerKhem Raj <raj.khem@gmail.com>2019-06-15 16:45:33 -0700
commit0fd7fa36218bc9e008b4bac115f40c0c3e80028f (patch)
tree7310326e6c646881b5ffeb89a00964a9a3d430b0 /meta-xfce
parent714d622b0b47ab0175f17da34486a781f3fe5ba9 (diff)
downloadmeta-openembedded-contrib-0fd7fa36218bc9e008b4bac115f40c0c3e80028f.tar.gz
xfce4-session: Reformat DEPENDS and RDEPENDS
Break them over multiple lines to make updates easier. Signed-off-by: Robert Joslyn <robert.joslyn@redrectangle.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-xfce')
-rw-r--r--meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.13.2.bb24
1 files changed, 22 insertions, 2 deletions
diff --git a/meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.13.2.bb b/meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.13.2.bb
index d6e3914304..dc44c4b0bd 100644
--- a/meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.13.2.bb
+++ b/meta-xfce/recipes-xfce/xfce4-session/xfce4-session_4.13.2.bb
@@ -2,8 +2,19 @@ SUMMARY = "xfce4-session is a session manager for Xfce 4 Desktop Environment"
SECTION = "x11"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=9ac2e7cff1ddaf48b6eab6028f23ef88"
-DEPENDS = "virtual/libx11 libsm libxfce4util libxfce4ui gtk+ libwnck3 dbus dbus-glib xfconf polkit"
-RDEPENDS_${PN} = "netbase xinit dbus-x11 iceauth upower xrdb"
+
+DEPENDS = " \
+ dbus \
+ dbus-glib \
+ gtk+ \
+ libwnck3 \
+ libsm \
+ libxfce4ui \
+ libxfce4util \
+ polkit \
+ virtual/libx11 \
+ xfconf \
+"
inherit xfce update-alternatives distro_features_check
@@ -26,3 +37,12 @@ FILES_${PN} += " \
${datadir}/themes/Default/balou/* \
${datadir}/polkit-1 \
"
+
+RDEPENDS_${PN} = " \
+ dbus-x11 \
+ iceauth \
+ netbase \
+ upower \
+ xinit \
+ xrdb \
+"