aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-01-03 11:40:58 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-01-03 12:02:34 +0100
commit156f6d3dc264c26f743a4359e4d40181a79ba038 (patch)
tree9dd3f8be261acb0a02cbc901d1cd70583351f93b /recipes-graphics
parentd178c04eb55df22f13efb5e5f8677e33fd26a83c (diff)
downloadmeta-openembedded-contrib-156f6d3dc264c26f743a4359e4d40181a79ba038.tar.gz
directfb from OE
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/directfb/++dfb/dfb-api-change.patch13
-rw-r--r--recipes-graphics/directfb/++dfb_1.0.0.bb21
-rw-r--r--recipes-graphics/directfb/directfb-1.2.8/ts_lib_autotools.patch22
-rw-r--r--recipes-graphics/directfb/directfb-1.4.6/mkdfiff.patch24
-rw-r--r--recipes-graphics/directfb/directfb-examples_1.0.0.bb14
-rw-r--r--recipes-graphics/directfb/directfb-examples_1.2.0.bb14
-rw-r--r--recipes-graphics/directfb/directfb.inc71
-rw-r--r--recipes-graphics/directfb/directfb_1.4.6.bb27
-rw-r--r--recipes-graphics/directfb/files/directfb-1.2.x-fix-pkgconfig-cflags.patch47
-rw-r--r--recipes-graphics/directfb/files/dont-use-linux-config.patch12
-rw-r--r--recipes-graphics/directfb/files/fix-font-missing-char.patch11
-rw-r--r--recipes-graphics/directfb/files/fix-pkgconfig-cflags.patch45
-rw-r--r--recipes-graphics/directfb/files/getpagesize.patch16
-rw-r--r--recipes-graphics/directfb/files/mkdfiff.patch11
-rw-r--r--recipes-graphics/directfb/files/ts_lib_autotools.patch16
-rw-r--r--recipes-graphics/directfb/files/use_limits_h.patch10
-rw-r--r--recipes-graphics/directfb/fusionsound-1.1.0+git20070709/fix-pkgconfig-cflags.patch23
-rw-r--r--recipes-graphics/directfb/fusionsound_1.1.0+git20070709.bb55
-rw-r--r--recipes-graphics/directfb/lite_0.9.26+cvs20070207.bb36
19 files changed, 488 insertions, 0 deletions
diff --git a/recipes-graphics/directfb/++dfb/dfb-api-change.patch b/recipes-graphics/directfb/++dfb/dfb-api-change.patch
new file mode 100644
index 0000000000..bec4e4cd85
--- /dev/null
+++ b/recipes-graphics/directfb/++dfb/dfb-api-change.patch
@@ -0,0 +1,13 @@
+diff -ruN ++DFB-1.0.0-orig/include/++dfb.h ++DFB-1.0.0/include/++dfb.h
+--- ++DFB-1.0.0-orig/include/++dfb.h 2007-02-02 23:48:36.000000000 +0100
++++ ++DFB-1.0.0/include/++dfb.h 2010-06-09 11:53:07.000000000 +0200
+@@ -46,6 +46,9 @@
+
+ #include <directfb.h>
+
++// Work around old lib expectations.
++typedef u8 __u8;
++
+ #undef IDirectFB
+ #undef IDirectFBScreen
+ #undef IDirectFBDisplayLayer
diff --git a/recipes-graphics/directfb/++dfb_1.0.0.bb b/recipes-graphics/directfb/++dfb_1.0.0.bb
new file mode 100644
index 0000000000..40413b95d9
--- /dev/null
+++ b/recipes-graphics/directfb/++dfb_1.0.0.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "A C++ Wrapper for the directfb framebuffer library."
+HOMEPAGE = "http://directfb.org"
+SECTION = "libs"
+DEPENDS = "directfb"
+LICENSE = "LGPL"
+
+PR = "r1"
+SRC_URI = "http://www.directfb.org/downloads/Extras/++DFB-${PV}.tar.gz \
+ file://dfb-api-change.patch"
+S = "${WORKDIR}/++DFB-${PV}"
+RV = "0.9-25"
+
+inherit autotools pkgconfig
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+}
+FILES_++dfb_append = " ${libdir}/*.so*"
+
+SRC_URI[md5sum] = "bfc2c45be253a5f25576587f61faff1b"
+SRC_URI[sha256sum] = "bc5b7766318ef6676defdf0103d1b53b48a3fee6b819fbe2076461caa9f94ec9"
diff --git a/recipes-graphics/directfb/directfb-1.2.8/ts_lib_autotools.patch b/recipes-graphics/directfb/directfb-1.2.8/ts_lib_autotools.patch
new file mode 100644
index 0000000000..7c34b567d9
--- /dev/null
+++ b/recipes-graphics/directfb/directfb-1.2.8/ts_lib_autotools.patch
@@ -0,0 +1,22 @@
+---
+ configure.in | 7 +++++--
+ 1 file changed, 5 insertions(+), 2 deletions(-)
+
+Index: DirectFB-1.2.8/configure.in
+===================================================================
+--- DirectFB-1.2.8.orig/configure.in
++++ DirectFB-1.2.8/configure.in
+@@ -1288,8 +1288,11 @@ fi
+
+ enable_tslib=no
+ if test "$checkfor_tslib" = "yes"; then
+- PKG_CHECK_MODULES([TSLIB], [tslib-0.0], [enable_tslib=yes], [enable_tslib=no,
+- AC_MSG_WARN([*** no tslib -- tslib driver will not be built.])])
++ PKG_CHECK_MODULES([TSLIB], [tslib-1.0 >= 1.0.0], [enable_tslib=yes], [enable_tslib=no])
++ if test "$enable_tslib" = "no"; then
++ PKG_CHECK_MODULES([TSLIB], [tslib-0.0], [enable_tslib=yes], [enable_tslib=no,
++ AC_MSG_WARN([*** no tslib -- tslib driver will not be built.])])
++ fi
+ fi
+
+ enable_ucb1x00_ts=no
diff --git a/recipes-graphics/directfb/directfb-1.4.6/mkdfiff.patch b/recipes-graphics/directfb/directfb-1.4.6/mkdfiff.patch
new file mode 100644
index 0000000000..28bd534f37
--- /dev/null
+++ b/recipes-graphics/directfb/directfb-1.4.6/mkdfiff.patch
@@ -0,0 +1,24 @@
+diff -uNr DirectFB-1.4.6.orig/tools/mkdfiff.c DirectFB-1.4.6/tools/mkdfiff.c
+--- DirectFB-1.4.6.orig/tools/mkdfiff.c 2010-10-15 10:54:57.000000000 +0200
++++ DirectFB-1.4.6/tools/mkdfiff.c 2010-10-15 10:54:15.000000000 +0200
+@@ -50,6 +50,8 @@
+
+ #include <dfiff.h>
+
++#include <unistd.h>
++
+ static DirectFBPixelFormatNames( format_names );
+
+ static const char *filename;
+diff -uNr DirectFB-1.4.6.orig/tools/mkdgifft.cpp DirectFB-1.4.6/tools/mkdgifft.cpp
+--- DirectFB-1.4.6.orig/tools/mkdgifft.cpp 2010-10-08 14:02:57.000000000 +0200
++++ DirectFB-1.4.6/tools/mkdgifft.cpp 2010-10-15 10:56:06.000000000 +0200
+@@ -40,6 +40,8 @@
+ #include <errno.h>
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <sys/stat.h>
++#include <sys/types.h>
+ #include <unistd.h>
+ #include <fcntl.h>
+ #include <sys/mman.h>
diff --git a/recipes-graphics/directfb/directfb-examples_1.0.0.bb b/recipes-graphics/directfb/directfb-examples_1.0.0.bb
new file mode 100644
index 0000000000..a6a374d6ad
--- /dev/null
+++ b/recipes-graphics/directfb/directfb-examples_1.0.0.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "DirectFB extra providers"
+DEPENDS = "directfb"
+SECTION = "libs"
+LICENSE = "GPL"
+
+SRC_URI = " \
+ http://www.directfb.org/downloads/Old/DirectFB-examples-${PV}.tar.gz \
+ "
+S = "${WORKDIR}/DirectFB-examples-${PV}"
+
+inherit autotools
+
+SRC_URI[md5sum] = "0cdfb4dd248eada3dc35db4f8cf75f8d"
+SRC_URI[sha256sum] = "c54e779a720841126e23d692de85243e23b0d94fb7792a958b96b5bd097a8b85"
diff --git a/recipes-graphics/directfb/directfb-examples_1.2.0.bb b/recipes-graphics/directfb/directfb-examples_1.2.0.bb
new file mode 100644
index 0000000000..6040bc35d1
--- /dev/null
+++ b/recipes-graphics/directfb/directfb-examples_1.2.0.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "DirectFB extra providers"
+DEPENDS = "directfb"
+SECTION = "libs"
+LICENSE = "GPL"
+
+SRC_URI = " \
+ http://www.directfb.org/downloads/Extras/DirectFB-examples-${PV}.tar.gz \
+ "
+S = "${WORKDIR}/DirectFB-examples-${PV}"
+
+inherit autotools
+
+SRC_URI[md5sum] = "ce018f681b469a1d72ffc32650304b98"
+SRC_URI[sha256sum] = "830a1bd6775d8680523596a88a72fd8e4c6a74bf886d3e169b06d234a5cf7e3e"
diff --git a/recipes-graphics/directfb/directfb.inc b/recipes-graphics/directfb/directfb.inc
new file mode 100644
index 0000000000..d07d58c113
--- /dev/null
+++ b/recipes-graphics/directfb/directfb.inc
@@ -0,0 +1,71 @@
+DESCRIPTION = "DirectFB is a thin library that provides developers \
+with hardware graphics acceleration, input device handling and \
+abstraction, an integrated windowing system with support for \
+translucent windows and multiple display layers on top of the \
+Linux framebuffer device."
+SECTION = "libs"
+LICENSE = "LGPL"
+HOMEPAGE = "http://directfb.org"
+DEPENDS = "jpeg libpng freetype zlib tslib"
+
+SRC_URI = " \
+ http://www.directfb.org/downloads/Old/DirectFB-${PV}.tar.gz \
+ file://fix-pkgconfig-cflags.patch \
+ file://fix-font-missing-char.patch \
+ file://getpagesize.patch \
+ file://mkdfiff.patch \
+ file://dont-use-linux-config.patch \
+ file://ts_lib_autotools.patch \
+"
+S = "${WORKDIR}/DirectFB-${PV}"
+
+LDFLAGS_append =" -lts -lm"
+
+inherit autotools binconfig pkgconfig
+
+EXTRA_OECONF = "\
+ --with-gfxdrivers=none \
+ --enable-libmpeg3=no \
+ --enable-freetype=yes \
+ --enable-sdl=no \
+ --enable-vnc=no \
+ --disable-x11 \
+"
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+}
+
+
+#PACKAGES_DYNAMIC = "directfb-inputdrivers-*"
+#
+#python populate_packages_prepend () {
+# import os.path
+# inputdrivers_libdir = bb.data.expand('${libdir}/directfb-${RV}/inputdrivers', d)
+# do_split_packages(d, inputdrivers_libdir, '*.so$', 'directfb-inputdrivers-%s', 'Directfb plugin for %s')
+#}
+
+# NOTE: monolithic packaging for now, should improve that eventually
+
+
+
+FILES_${PN}-dbg += "\
+ ${libdir}/directfb-${RV}/*/*/.debug/*.so \
+ ${libdir}/directfb-${RV}/*/.debug/*.so \
+"
+
+FILES_${PN}-dev += "\
+ ${bindir}/directfb-config \
+ ${libdir}/directfb-${RV}/systems/*.la \
+ ${libdir}/directfb-${RV}/inputdrivers/*.la \
+ ${libdir}/directfb-${RV}/interfaces/*/*.la \
+ ${libdir}/directfb-${RV}/wm/*.la \
+"
+
+FILES_${PN} += "\
+ ${libdir}/directfb-${RV}/systems/*.so \
+ ${libdir}/directfb-${RV}/inputdrivers/*.so \
+ ${libdir}/directfb-${RV}/interfaces/*/*.so \
+ ${libdir}/directfb-${RV}/wm/*.so \
+ ${datadir}/directfb-${PV} \
+"
diff --git a/recipes-graphics/directfb/directfb_1.4.6.bb b/recipes-graphics/directfb/directfb_1.4.6.bb
new file mode 100644
index 0000000000..70c0225bf7
--- /dev/null
+++ b/recipes-graphics/directfb/directfb_1.4.6.bb
@@ -0,0 +1,27 @@
+require directfb.inc
+
+RV = "1.4-5"
+PR = "r2"
+
+DEPENDS += "sysfsutils"
+
+SRC_URI = " \
+ http://directfb.org/downloads/Core/DirectFB-1.4/DirectFB-${PV}.tar.gz \
+ file://directfb-1.2.x-fix-pkgconfig-cflags.patch \
+ file://mkdfiff.patch \
+ file://dont-use-linux-config.patch \
+ "
+
+EXTRA_OECONF = "\
+ --enable-freetype=yes \
+ --enable-zlib \
+ --with-gfxdrivers=none \
+ --disable-sdl \
+ --disable-vnc \
+ --disable-x11 \
+"
+
+LEAD_SONAME = "libdirectfb-1.4.so.5"
+
+SRC_URI[md5sum] = "dbe1957932f81790742b58b94c1c7b84"
+SRC_URI[sha256sum] = "b18121e60e9a084ee347037a53a46cfaea1c09505bd99d673c2e65eca285e69b"
diff --git a/recipes-graphics/directfb/files/directfb-1.2.x-fix-pkgconfig-cflags.patch b/recipes-graphics/directfb/files/directfb-1.2.x-fix-pkgconfig-cflags.patch
new file mode 100644
index 0000000000..745c561cc0
--- /dev/null
+++ b/recipes-graphics/directfb/files/directfb-1.2.x-fix-pkgconfig-cflags.patch
@@ -0,0 +1,47 @@
+Index: DirectFB-1.1.1/directfb-internal.pc.in
+===================================================================
+--- DirectFB-1.1.1.orig/directfb-internal.pc.in 2007-08-07 21:43:00.000000000 +0200
++++ DirectFB-1.1.1/directfb-internal.pc.in 2008-07-17 21:00:47.424654304 +0200
+@@ -2,10 +2,10 @@
+ exec_prefix=@exec_prefix@
+ moduledir=@MODULEDIR@
+ moduledirname=@MODULEDIRNAME@
+-includedir=@INTERNALINCLUDEDIR@
++includedir=@includedir@
+
+ Name: DirectFB-Internal
+ Description: Third party module support package for DirectFB.
+ Version: @VERSION@
+ Requires: directfb = @VERSION@
+-Cflags: @DFB_INTERNAL_CFLAGS@ -I@INTERNALINCLUDEDIR@
++Cflags: @DFB_INTERNAL_CFLAGS@ -I${includedir}/directfb -I${includedir}
+Index: DirectFB-1.1.1/directfb.pc.in
+===================================================================
+--- DirectFB-1.1.1.orig/directfb.pc.in 2007-12-15 16:23:16.000000000 +0100
++++ DirectFB-1.1.1/directfb.pc.in 2008-07-17 20:59:58.044985193 +0200
+@@ -9,4 +9,4 @@
+ Requires: fusion direct
+ Libs: -L${libdir} -ldirectfb @THREADLIB@ @OSX_LIBS@
+ Libs.private: -L${libdir} @DYNLIB@ @ZLIB_LIBS@
+-Cflags: @THREADFLAGS@ -I@INCLUDEDIR@
++Cflags: @THREADFLAGS@ -I${includedir}/directfb
+Index: DirectFB-1.1.1/lib/fusion/fusion.pc.in
+===================================================================
+--- DirectFB-1.1.1.orig/lib/fusion/fusion.pc.in 2007-08-07 21:43:00.000000000 +0200
++++ DirectFB-1.1.1/lib/fusion/fusion.pc.in 2008-07-17 20:58:07.051338866 +0200
+@@ -8,4 +8,4 @@
+ Version: @VERSION@
+ Requires: direct
+ Libs: -L${libdir} -lfusion
+-Cflags: -I@INCLUDEDIR@
++Cflags: -I${includedir}/directfb -I${includedir}
+Index: DirectFB-1.1.1/lib/voodoo/voodoo.pc.in
+===================================================================
+--- DirectFB-1.1.1.orig/lib/voodoo/voodoo.pc.in 2007-08-07 21:43:00.000000000 +0200
++++ DirectFB-1.1.1/lib/voodoo/voodoo.pc.in 2008-07-17 20:58:07.054671842 +0200
+@@ -8,4 +8,4 @@
+ Version: @VERSION@
+ Requires: direct
+ Libs: -L${libdir} -lvoodoo
+-Cflags: -I@INCLUDEDIR@
++Cflags: -I${includedir}/directfb -I${includedir}
diff --git a/recipes-graphics/directfb/files/dont-use-linux-config.patch b/recipes-graphics/directfb/files/dont-use-linux-config.patch
new file mode 100644
index 0000000000..f971660954
--- /dev/null
+++ b/recipes-graphics/directfb/files/dont-use-linux-config.patch
@@ -0,0 +1,12 @@
+diff -urN DirectFB-1.1.0.orig/lib/direct/ppcasm_memcpy_cachable.S DirectFB-1.1.0/lib/direct/ppcasm_memcpy_cachable.S
+--- DirectFB-1.1.0.orig/lib/direct/ppcasm_memcpy_cachable.S 2007-08-07 21:43:00.000000000 +0200
++++ DirectFB-1.1.0/lib/direct/ppcasm_memcpy_cachable.S 2008-06-07 04:14:26.000000000 +0200
+@@ -34,8 +34,6 @@
+
+ #define __ASSEMBLY__
+
+-#include <linux/config.h>
+-
+ #if defined(CONFIG_8xx) || defined(CONFIG_403GCX)
+ #define L1_CACHE_LINE_SIZE 16
+ #define LG_L1_CACHE_LINE_SIZE 4
diff --git a/recipes-graphics/directfb/files/fix-font-missing-char.patch b/recipes-graphics/directfb/files/fix-font-missing-char.patch
new file mode 100644
index 0000000000..4c5e5883f4
--- /dev/null
+++ b/recipes-graphics/directfb/files/fix-font-missing-char.patch
@@ -0,0 +1,11 @@
+--- git/src/media/idirectfbfont.c~org 2007-07-10 10:35:46.000000000 -0400
++++ git/src/media/idirectfbfont.c 2007-07-10 10:36:09.000000000 -0400
+@@ -497,7 +497,7 @@
+
+ if (width<max_width && string >= end) {
+ *ret_next_line = NULL;
+- *ret_str_length = length-1;
++ *ret_str_length = length;
+ *ret_width = width;
+
+ return DFB_OK;
diff --git a/recipes-graphics/directfb/files/fix-pkgconfig-cflags.patch b/recipes-graphics/directfb/files/fix-pkgconfig-cflags.patch
new file mode 100644
index 0000000000..ddaa276fcd
--- /dev/null
+++ b/recipes-graphics/directfb/files/fix-pkgconfig-cflags.patch
@@ -0,0 +1,45 @@
+diff -ur DirectFB-1.0.0~org/directfb-internal.pc.in DirectFB-1.0.0/directfb-internal.pc.in
+--- DirectFB-1.0.0~org/directfb-internal.pc.in 2003-07-04 13:30:22.000000000 -0400
++++ DirectFB-1.0.0/directfb-internal.pc.in 2007-03-16 22:34:17.000000000 -0400
+@@ -8,4 +8,4 @@
+ Description: Third party module support package for DirectFB.
+ Version: @VERSION@
+ Requires: directfb = @VERSION@
+-Cflags: @DFB_INTERNAL_CFLAGS@ -I@INTERNALINCLUDEDIR@
++Cflags: @DFB_INTERNAL_CFLAGS@ -I${includedir}/directfb -I${includedir}
+diff -ur DirectFB-1.0.0~org/directfb.pc.in DirectFB-1.0.0/directfb.pc.in
+--- DirectFB-1.0.0~org/directfb.pc.in 2004-08-04 12:28:20.000000000 -0400
++++ DirectFB-1.0.0/directfb.pc.in 2007-03-16 22:31:33.000000000 -0400
+@@ -8,4 +8,4 @@
+ Version: @VERSION@
+ Requires: fusion direct
+ Libs: -L${libdir} -ldirectfb @THREADLIB@ @DYNLIB@ @ZLIB_LIBS@ @OSX_LIBS@
+-Cflags: @THREADFLAGS@ -I@INCLUDEDIR@
++Cflags: @THREADFLAGS@ -I${includedir}/directfb -I${includedir}
+diff -ur DirectFB-1.0.0~org/lib/direct/direct.pc.in DirectFB-1.0.0/lib/direct/direct.pc.in
+--- DirectFB-1.0.0~org/lib/direct/direct.pc.in 2005-11-23 09:18:59.000000000 -0500
++++ DirectFB-1.0.0/lib/direct/direct.pc.in 2007-03-16 22:32:13.000000000 -0400
+@@ -7,4 +7,4 @@
+ Description: DirectFB base development library
+ Version: @VERSION@
+ Libs: -L${libdir} -ldirect @THREADLIB@ @DYNLIB@
+-Cflags: @THREADFLAGS@ -I@INCLUDEDIR@
++Cflags: @THREADFLAGS@ -I${includedir}/directfb -I${includedir}
+diff -ur DirectFB-1.0.0~org/lib/fusion/fusion.pc.in DirectFB-1.0.0/lib/fusion/fusion.pc.in
+--- DirectFB-1.0.0~org/lib/fusion/fusion.pc.in 2004-05-19 07:30:56.000000000 -0400
++++ DirectFB-1.0.0/lib/fusion/fusion.pc.in 2007-03-16 22:32:34.000000000 -0400
+@@ -8,4 +8,4 @@
+ Version: @VERSION@
+ Requires: direct
+ Libs: -L${libdir} -lfusion
+-Cflags: -I@INCLUDEDIR@
++Cflags: -I${includedir}/directfb -I${includedir}
+diff -ur DirectFB-1.0.0~org/lib/voodoo/voodoo.pc.in DirectFB-1.0.0/lib/voodoo/voodoo.pc.in
+--- DirectFB-1.0.0~org/lib/voodoo/voodoo.pc.in 2004-05-19 07:31:28.000000000 -0400
++++ DirectFB-1.0.0/lib/voodoo/voodoo.pc.in 2007-03-16 22:32:55.000000000 -0400
+@@ -8,4 +8,4 @@
+ Version: @VERSION@
+ Requires: direct
+ Libs: -L${libdir} -lvoodoo
+-Cflags: -I@INCLUDEDIR@
++Cflags: -I${includedir}/directfb -I${includedir}
diff --git a/recipes-graphics/directfb/files/getpagesize.patch b/recipes-graphics/directfb/files/getpagesize.patch
new file mode 100644
index 0000000000..256b8db290
--- /dev/null
+++ b/recipes-graphics/directfb/files/getpagesize.patch
@@ -0,0 +1,16 @@
+diff --git a/lib/direct/system.c b/lib/direct/system.c
+index 8dd3f12..0731fa2 100644
+--- a/lib/direct/system.c
++++ b/lib/direct/system.c
+@@ -36,8 +36,9 @@
+
+ #if HAVE_ASM_PAGE_H
+ #include <asm/page.h>
+-#else
+-#define PAGE_SIZE sysconf( _SC_PAGESIZE )
++#endif
++#ifndef PAGE_SIZE
++# define PAGE_SIZE (getpagesize())
+ #endif
+
+
diff --git a/recipes-graphics/directfb/files/mkdfiff.patch b/recipes-graphics/directfb/files/mkdfiff.patch
new file mode 100644
index 0000000000..cb56fd3602
--- /dev/null
+++ b/recipes-graphics/directfb/files/mkdfiff.patch
@@ -0,0 +1,11 @@
+--- DirectFB-1.0.0-rc1~org/tools/mkdfiff.c 2006-10-12 13:45:50.000000000 -0400
++++ DirectFB-1.0.0-rc1/tools/mkdfiff.c 2006-10-12 13:57:38.000000000 -0400
+@@ -15,6 +15,8 @@
+
+ #include <dfiff.h>
+
++#include <unistd.h>
++
+ static DirectFBPixelFormatNames( format_names );
+
+ static const char *filename;
diff --git a/recipes-graphics/directfb/files/ts_lib_autotools.patch b/recipes-graphics/directfb/files/ts_lib_autotools.patch
new file mode 100644
index 0000000000..ced7104786
--- /dev/null
+++ b/recipes-graphics/directfb/files/ts_lib_autotools.patch
@@ -0,0 +1,16 @@
+Index: DirectFB-1.1.1/configure.in
+===================================================================
+--- DirectFB-1.1.1.orig/configure.in 2008-05-07 23:08:04.000000000 +0200
++++ DirectFB-1.1.1/configure.in 2008-05-07 23:15:43.000000000 +0200
+@@ -1292,8 +1292,11 @@
+
+ enable_tslib=no
+ if test "$checkfor_tslib" = "yes"; then
++ PKG_CHECK_MODULES([TSLIB], [tslib-1.0 >= 1.0.0], [enable_tslib=yes], [enable_tslib=no])
++ if test "$enable_tslib" = "no"; then
+ PKG_CHECK_MODULES([TSLIB], [tslib-0.0 >= 0.0.2], enable_tslib=yes, enable_tslib=no
+ AC_MSG_WARN([*** no tslib -- tslib driver will not be built.]))
++ fi
+ fi
+
+ enable_ucb1x00_ts=no
diff --git a/recipes-graphics/directfb/files/use_limits_h.patch b/recipes-graphics/directfb/files/use_limits_h.patch
new file mode 100644
index 0000000000..327cd7a163
--- /dev/null
+++ b/recipes-graphics/directfb/files/use_limits_h.patch
@@ -0,0 +1,10 @@
+--- FusionSound-1.0.0.orig/interfaces/IFusionSoundMusicProvider/ifusionsoundmusicprovider_cdda.c
++++ FusionSound-1.0.0/interfaces/IFusionSoundMusicProvider/ifusionsoundmusicprovider_cdda.c
+@@ -109,6 +109,7 @@ typedef struct {
+
+ #if defined(__linux__)
+
++#include <limits.h>
+ #include <linux/cdrom.h>
+
+ static DFBResult
diff --git a/recipes-graphics/directfb/fusionsound-1.1.0+git20070709/fix-pkgconfig-cflags.patch b/recipes-graphics/directfb/fusionsound-1.1.0+git20070709/fix-pkgconfig-cflags.patch
new file mode 100644
index 0000000000..0eb4c7519a
--- /dev/null
+++ b/recipes-graphics/directfb/fusionsound-1.1.0+git20070709/fix-pkgconfig-cflags.patch
@@ -0,0 +1,23 @@
+--- git/fusionsound.pc.in~org 2008-08-19 11:04:27.000000000 -0400
++++ git/fusionsound.pc.in 2008-08-19 11:06:20.000000000 -0400
+@@ -8,4 +8,4 @@
+ Description: Multi application sound streaming and mixing
+ Version: @VERSION@
+ Libs: -L${libdir} -lfusionsound
+-Cflags: -I@INCLUDEDIR@
++Cflags: -I${includedir}/fusionsound
+--- git/fusionsound-internal.pc.in~org 2008-08-19 11:11:57.000000000 -0400
++++ git/fusionsound-internal.pc.in 2008-08-19 11:08:31.000000000 -0400
+@@ -1,10 +1,10 @@
+ prefix=@prefix@
+ exec_prefix=@exec_prefix@
+ moduledir=@MODULEDIR@
+-includedir=@INTERNALINCLUDEDIR@
++includedir=@includedir@
+
+ Name: FusionSound-Internal
+ Description: Third party module support package for FusionSound.
+ Version: @VERSION@
+ Requires: fusionsound = @VERSION@
+-Cflags: -I@INTERNALINCLUDEDIR@
++Cflags: -I${includedir}/fusionsound -I${includedir}
diff --git a/recipes-graphics/directfb/fusionsound_1.1.0+git20070709.bb b/recipes-graphics/directfb/fusionsound_1.1.0+git20070709.bb
new file mode 100644
index 0000000000..2b580190c5
--- /dev/null
+++ b/recipes-graphics/directfb/fusionsound_1.1.0+git20070709.bb
@@ -0,0 +1,55 @@
+DESCRIPTION = "FusionSound for DirectFB"
+DEPENDS = "directfb"
+SECTION = "libs"
+LICENSE = "LGPL"
+PR = "r2"
+
+SRC_URI = "git://git.directfb.org/git/directfb/core/FusionSound;protocol=git;tag=0b2162b570c8314fd1240b08d6ab4a8d074ccf37 \
+ file://fix-pkgconfig-cflags.patch \
+ file://use_limits_h.patch \
+"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+CFLAGS_append += " -I${STAGING_INCDIR}/directfb -I${STAGING_INCDIR}/directfb-internal"
+
+#Below are some of the configure options
+EXTRA_OECONF = " \
+ --disable-ieee-floats \
+ --disable-precision \
+ --enable-linear-filter \
+ --disable-dithering \
+ --enable-debug \
+ --enable-examples \
+ --enable-module \
+ --disable-timidity \
+ --disable-wave \
+ --enable-vorbis \
+ --enable-tremor \
+ --disable-mad \
+ --disable-cdda \
+ --disable-playlist \
+ "
+
+do_configure_append() {
+ find ${S} -type f | xargs sed -i 's:I/usr/include:I${STAGING_INCDIR}:g'
+}
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+}
+
+FILES_fusionsound-dbg_append = " ${libdir}/directfb-1.1-0/*/*/.debug/*.so \
+ ${libdir}/directfb-1.1-0/*/.debug/*.so \
+ "
+
+FILES_fusionsound-dev_append = " ${libdir}/directfb-1.1-0/interfaces/*/*.la \
+ ${libdir}/directfb-1.1-0/snddrivers/*.la \
+ "
+
+FILES_fusionsound_append = " ${libdir}/directfb-1.1-0/interfaces/*/*.so \
+ ${libdir}/directfb-1.1-0/snddrivers/*.so \
+ "
+
diff --git a/recipes-graphics/directfb/lite_0.9.26+cvs20070207.bb b/recipes-graphics/directfb/lite_0.9.26+cvs20070207.bb
new file mode 100644
index 0000000000..231a1efeca
--- /dev/null
+++ b/recipes-graphics/directfb/lite_0.9.26+cvs20070207.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "LiTE stands for Lightweight Toolkit Enabler. Its role is to \
+ facilitate the functions of DirectFB so that a toolbox could \
+ be written on top of DirectFB with less effort. As such LiTE \
+ has abstractions for the underlying graphics and event systems."
+
+DEPENDS = "directfb"
+SECTION = "libs"
+LICENSE = "LGPL"
+
+# this is a CVS only release
+
+SRC_URI = "cvs://anonymous@cvs.directfb.org/cvs/directfb;method=pserver;module=lite;date=${@bb.data.getVar('PV', d, 1)[10:]}"
+
+S = "${WORKDIR}/lite"
+
+inherit autotools pkgconfig
+
+do_configure_append() {
+ find ${S} -type f | xargs sed -i 's:I/usr/include:I${STAGING_INCDIR}:g'
+}
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+}
+
+FILES_lite-dbg_append = " ${libdir}/directfb-1.0-0/*/*/.debug/*.so \
+ ${libdir}/directfb-1.0-0/*/.debug/*.so \
+ "
+FILES_lite-dev_append = " ${libdir}/directfb-1.0-0/interfaces/*/*.la \
+ "
+
+FILES_lite_append = " ${libdir}/directfb-1.0-0/interfaces/*/*.so \
+ ${datadir}/LiTE/* \
+ ${datadir}/fonts/truetype/* \
+ "
+