aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-pandas.inc23
-rw-r--r--meta-python/recipes-devtools/python/python-pandas_0.20.3.bb7
-rw-r--r--meta-python/recipes-devtools/python/python3-pandas_0.20.3.bb2
3 files changed, 32 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pandas.inc b/meta-python/recipes-devtools/python/python-pandas.inc
new file mode 100644
index 0000000000..d1f3707a56
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pandas.inc
@@ -0,0 +1,23 @@
+SUMMARY = "pandas library for high-performance data analysis tools"
+DESCRIPTION = "pandas is an open source, BSD-licensed library providing \
+high-performance, easy-to-use data structures and data analysis tools for \
+the Python programming language."
+HOMEPAGE = "http://pandas.pydata.org/"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=66017d3134349017409386be85176145"
+
+SRC_URI[md5sum] = "4df858f28b4bf4fa07d9fbb7f2568173"
+SRC_URI[sha256sum] = "a777e07633d83d546c55706420179551c8e01075b53c497dcf8ae4036766bc66"
+
+PYPI_PACKAGE = "pandas"
+inherit pypi
+
+DEPENDS += " \
+ ${PYTHON_PN}-numpy-native \
+"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-numpy \
+ ${PYTHON_PN}-dateutil \
+ ${PYTHON_PN}-pytz \
+"
diff --git a/meta-python/recipes-devtools/python/python-pandas_0.20.3.bb b/meta-python/recipes-devtools/python/python-pandas_0.20.3.bb
new file mode 100644
index 0000000000..20973c8e84
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pandas_0.20.3.bb
@@ -0,0 +1,7 @@
+inherit setuptools
+require python-pandas.inc
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-importlib \
+"
diff --git a/meta-python/recipes-devtools/python/python3-pandas_0.20.3.bb b/meta-python/recipes-devtools/python/python3-pandas_0.20.3.bb
new file mode 100644
index 0000000000..b5dd5e0924
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pandas_0.20.3.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-pandas.inc