aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-pymongo.inc12
-rw-r--r--meta-python/recipes-devtools/python/python-pymongo_3.2.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pymongo_3.2.bb2
3 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pymongo.inc b/meta-python/recipes-devtools/python/python-pymongo.inc
new file mode 100644
index 0000000000..5cdd5bdf53
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pymongo.inc
@@ -0,0 +1,12 @@
+SUMMARY = "Python driver for MongoDB <http://www.mongodb.org>"
+DESCRIPTION = "\
+The PyMongo distribution contains tools for interacting with MongoDB \
+database from Python. The bson package is an implementation of the BSON \
+format for Python. The pymongo package is a native Python driver for \
+MongoDB. The gridfs package is a gridfs implementation on top of pymongo."
+HOMEPAGE = "http://github.com/mongodb/mongo-python-driver"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2a944942e1496af1886903d274dedb13"
+
+SRC_URI[md5sum] = "463b4d325d8fb4070c04f15391b457bf"
+SRC_URI[sha256sum] = "f50a5380b45a83c5ea1e673ff19363d3cfd5850f7620536e51341d26eb2ae979"
diff --git a/meta-python/recipes-devtools/python/python-pymongo_3.2.bb b/meta-python/recipes-devtools/python/python-pymongo_3.2.bb
new file mode 100644
index 0000000000..4038898036
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pymongo_3.2.bb
@@ -0,0 +1,2 @@
+inherit pypi
+require python-pymongo.inc
diff --git a/meta-python/recipes-devtools/python/python3-pymongo_3.2.bb b/meta-python/recipes-devtools/python/python3-pymongo_3.2.bb
new file mode 100644
index 0000000000..d2cfd55661
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pymongo_3.2.bb
@@ -0,0 +1,2 @@
+inherit pypi3
+require python-pymongo.inc