aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb b/meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb
index 43e69b93ae..78b943247d 100644
--- a/meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb
+++ b/meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb
@@ -16,6 +16,10 @@ SRC_URI[sha256sum] = "e3f9427b27c5bddf898d383d45c0d3d5397e2056ff935d9a5cdaef6a9a
inherit autotools-brokensep pkgconfig binconfig
+# Upstream is currently working on porting the code to use std::unique_ptr instead of the
+# deprecated auto_ptr. For now, ignore the issue.
+CXXFLAGS += "-Wno-error=deprecated-declarations"
+
PACKAGES =+ "libcurlpp libcurlpp-dev libcurlpp-staticdev"
FILES_lib${BPN} = "${libdir}/lib*.so.* \
@@ -29,6 +33,3 @@ FILES_lib${BPN}-dev = "${includedir} \
FILES_lib${BPN}-staticdev = "${libdir}/lib*.a"
BBCLASSEXTEND = "native nativesdk"
-
-# http://errors.yoctoproject.org/Errors/Details/68623/
-PNBLACKLIST[curlpp] ?= "BROKEN: fails to build with gcc-6"