aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-networking/recipes-support/ntp/ntp_4.2.8p8.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/ntp/ntp_4.2.8p8.bb b/meta-networking/recipes-support/ntp/ntp_4.2.8p8.bb
index bca5a07458..f3344c0b50 100644
--- a/meta-networking/recipes-support/ntp/ntp_4.2.8p8.bb
+++ b/meta-networking/recipes-support/ntp/ntp_4.2.8p8.bb
@@ -46,7 +46,9 @@ USERADD_PARAM_${PN} = "--system --home-dir ${NTP_USER_HOME} \
--shell /bin/false --user-group ntp"
# NB: debug is default-enabled by NTP; keep it default-enabled here.
-PACKAGECONFIG ??= "cap debug refclocks"
+PACKAGECONFIG ??= "cap debug refclocks \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)} \
+"
PACKAGECONFIG[openssl] = "--with-openssl-libdir=${STAGING_LIBDIR} \
--with-openssl-incdir=${STAGING_INCDIR} \
--with-crypto, \
@@ -57,6 +59,7 @@ PACKAGECONFIG[readline] = "--with-lineeditlibs,--without-lineeditlibs,readline"
PACKAGECONFIG[refclocks] = "--enable-all-clocks,--disable-all-clocks,pps-tools"
PACKAGECONFIG[debug] = "--enable-debugging,--disable-debugging"
PACKAGECONFIG[mdns] = "ac_cv_header_dns_sd_h=yes,ac_cv_header_dns_sd_h=no,mdns"
+PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
do_install_append() {
install -d ${D}${sysconfdir}/init.d