aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-support/start-stop-daemon/start-stop-daemon_1.17.25.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/start-stop-daemon/start-stop-daemon_1.17.25.bb b/meta-oe/recipes-support/start-stop-daemon/start-stop-daemon_1.17.25.bb
index 5ee4472cd9..cc2727b758 100644
--- a/meta-oe/recipes-support/start-stop-daemon/start-stop-daemon_1.17.25.bb
+++ b/meta-oe/recipes-support/start-stop-daemon/start-stop-daemon_1.17.25.bb
@@ -31,6 +31,8 @@ do_install_append () {
# support for buggy init.d scripts that refer to an alternative
# explicit path to start-stop-daemon
- mkdir -p ${D}/sbin/
- ln -sf /usr/sbin/start-stop-daemon ${D}/sbin/start-stop-daemon
+ if [ "${base_sbindir}" != "${sbindir}" ]; then
+ mkdir -p ${D}${base_sbindir}
+ ln -sf ${sbindir}/start-stop-daemon ${D}${base_sbindir}/start-stop-daemon
+ fi
}