aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-networking/recipes-irc/znc/znc_git.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-networking/recipes-irc/znc/znc_git.bb b/meta-networking/recipes-irc/znc/znc_git.bb
new file mode 100644
index 0000000000..aea8ed4923
--- /dev/null
+++ b/meta-networking/recipes-irc/znc/znc_git.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "ZNC, an advanced IRC bouncer"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
+
+DEPENDS = "openssl"
+
+PV = "1.0+git"
+
+SRCREV = "ef59c23068547c132cb678092fba9a21317fd5f2"
+SRC_URI = "git://github.com/znc/znc.git"
+
+S = "${WORKDIR}/git"
+
+inherit autotools
+
+# ZNC has a custom autogen.sh that states that this command is needed *and* expected to fail
+do_configure_prepend() {
+ automake --add-missing || true
+}