aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-devtools/php/php_5.6.26.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/php/php_5.6.26.bb b/meta-oe/recipes-devtools/php/php_5.6.26.bb
index dfce949f92..7e566b1ba2 100644
--- a/meta-oe/recipes-devtools/php/php_5.6.26.bb
+++ b/meta-oe/recipes-devtools/php/php_5.6.26.bb
@@ -8,3 +8,12 @@ SRC_URI += "file://change-AC_TRY_RUN-to-AC_TRY_LINK.patch \
"
SRC_URI[md5sum] = "cb424b705cfb715fc04f499f8a8cf52e"
SRC_URI[sha256sum] = "d47aab8083a4284b905777e1b45dd7735adc53be827b29f896684750ac8b6236"
+
+python () {
+ ver = d.getVar('PV')
+ if not d.getVar('php_'+ver+'_OK'):
+ msg = "%s disables itself because of many outstanding CVEs!" % (ver)
+ msg = msg + " Define php_%s_OK = '1' to build it." % (ver)
+ raise bb.parse.SkipPackage(msg)
+}
+